Bug 149549 - netatalk/at.h from netatalk-devel conflicts with glibc-headers
Summary: netatalk/at.h from netatalk-devel conflicts with glibc-headers
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 151523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-23 21:55 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 04:47:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2005-02-23 21:55:18 UTC
Description of problem:
Updating an `everything' rawhide install to today's rawhide produces
this error in up2date:

file /usr/include/netatalk/at.h from install of netatalk-devel-2.0.2-1
conflicts with file from package glibc-headers-2.3.4-10

Version-Release number of selected component (if applicable):
netatalk-devel-2.0.2-1 glibc-headers-2.3.4-10

Comment 1 Jason Vas Dias 2005-02-23 22:45:06 UTC
This is very weird. There is no reason why glibc-headers should be
installing the netatalk header files - they should only be installed
by netatalk devel. Even if glibc-headers does need to install a certain
version of atalk headers, they need to be upgraded to match the latest
version of the netatalk libraries, and should be able to be updated 
by netatalk-devel - glibc-headers should hence have a dependency on 
netatalk devel instead. I'm moving this bug to glibc.



Comment 2 Jason Vas Dias 2005-02-23 22:47:43 UTC
glibc-headers should not be including headers from netatalk-devel .
If glibc-headers actually needs the netatalk header files, it should
have a dependancy on netatalk-devel instead of "providing" them.


Comment 3 Ulrich Drepper 2005-02-24 01:24:03 UTC
glibc provides a number of headers for protocols.  This is how it always has
been.  People don't want to install all of the netatalk stuff just to be able to
get the value for SOL_ATALK etc.

If the header is out of date (or more correctly, <linux/atalk.h> in
glibc-kernheader, this is another issue.  That package can be updated.

Comment 4 Jakub Jelinek 2005-03-20 14:55:11 UTC
*** Bug 151523 has been marked as a duplicate of this bug. ***

Comment 5 Ulrich Drepper 2005-07-25 22:19:53 UTC
Well, what is happening?  What is in the <netatalk/at.h> file from
netatalk-devel that isn't in glibc's version?  If there is anything, report it.
 Otherwise just remove that file from the netatalk-devel package.

Comment 6 Alexandre Oliva 2005-07-26 21:41:11 UTC
It appears that, even if the files are bit-by-bit identical, up2date still
reports conflicts.  I haven't had any such problems since I switched to yum, and
there have been updates to both glibc and netatalk.  Not sure how to proceed on
this.  Feel free to close as far as I'm concerned.

Comment 7 Ulrich Drepper 2005-07-27 04:47:38 UTC
I'm closing it.  Seems to work now.  If not, somebody will file a new bug.


Note You need to log in before you can comment on or make changes to this bug.