Bug 149594 - Turkish Locale i and capital i problem
Turkish Locale i and capital i problem
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 06:49 EST by Fırat KÜÇÜK
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-10 14:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trq.map which doesn't hardcode iso-8859-9 (3.69 KB, text/plain)
2005-04-12 16:39 EDT, Miloslav Trmač
no flags Details
Corrected trq.map, tested in UTF-8 setting (3.75 KB, text/plain)
2006-01-30 17:23 EST, Ozgur M. Homurlu
no flags Details

  None (edit)
Description Fırat KÜÇÜK 2005-02-24 06:49:24 EST
Description of problem:
LANG variable   = tr_TR.UTF-8 and also tr_TR
keyboard layout = trq

caps lock = off
  "ı" -> "ý"
  <shift> + "İ" -> "Ý"
caps lock = on
  "ı" -> "ý"
  <shift> + "i" -> "Ý"
  "i" -> no output
  <shift> + "ı" -> no output
  <shift> + "i" -> no output

under X
caps lock = on
  "ı" -> "ı"
  "i" -> "I"

Version-Release number of selected component (if applicable):
all releases

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
font, wrong trq map

Additional info:
Comment 1 Tim Waugh 2005-02-25 10:32:31 EST
Is it the same on VT2?
Comment 2 Fırat KÜÇÜK 2005-02-25 12:46:16 EST
it occurs on all linux distros and and all programs!
Comment 3 Tim Waugh 2005-02-25 12:51:01 EST
Let me rephrase the question:

I'm assuming that your description above, before the line "under X", applies to
the Linux text console -- also, I'm assuming that you are using the first
virtual terminal, VT1.  In other words, the virtual terminal you get with
Ctrl-Alt-F1.

Does the same thing happen when you use the virtual terminal on Ctrl-Alt-F2?
Comment 4 Fırat KÜÇÜK 2005-02-25 17:24:38 EST
yes on all virtual terminal, on all other distros, on all other computers.
Comment 5 Fırat KÜÇÜK 2005-02-25 20:25:10 EST
I changed the LANG variable from tr_TR.UTF-8 to tr_TR. (/etc/sysconfig/i18n)
and changed th default font from latarcyrheb-sun16 to lat5-16.psfu

Problem fixed under virtual terminals.

These situation shows that there is no unicode trq keymap for virtual terminals.

Under X problem is still goes on.

the right output should be like this:
i <-> Ä°
ı <-> I
ğ <-> Ğ
ç <-> Ç
ö <-> Ö
Comment 6 Tim Waugh 2005-04-04 08:56:31 EDT
Changing component to kbd, which owns keymaps.
Comment 7 Miloslav Trmač 2005-04-12 16:39:32 EDT
Created attachment 113056 [details]
trq.map which doesn't hardcode iso-8859-9

Please try the attached map, both in iso-8859-9:
      (loadkeys $PATH_TO_DOWNLOADED/trq.map)
and UTF-8:
      (loadkeys -u $PATH_TO_DOWNLOADED/trq.map)
and let me know the results.

It seems to work correctly here, but then I have never seen a Turkish
keyboard...

If some key still doesn't work correctly, please mention not only the expected
and actual results, but also which key it is (e.g. by comparing it to the US
layout or by pointing me to a picture.)
Comment 8 Fırat KÜÇÜK 2005-04-13 02:46:46 EDT
If added the following statement to xorg.conf.

Option "XkbOptions" "caps:shift"

problem is fixed.

may it be default configration via anaconda?
Comment 9 Miloslav Trmač 2005-04-13 04:31:46 EDT
X and virtual terminal keymaps are completely unrelated, please open a separate
bug report for X keymaps.

Does the trq.map attached above work on the virtual terminal?
Comment 10 Miloslav Trmač 2005-06-10 14:38:33 EDT
I have sent the modified trq map upstream, it will appear in Fedora with
the next kbd release.
Thanks for your report.
Comment 11 Ozgur M. Homurlu 2006-01-30 15:11:52 EST
I have tested attachment map. It's OK except the following problems: 
 
1) Alt Gr-5 output should be "½" (1 over 2 symbol) 
2) Alt Gr-e output should be "€" (Euro currency symbol) 
3) Alt Gr-ş (scedilla, keycode 39) output should be "´" (symmetric of `) 
 
Please fix these problems before the next release. Especially, the Euro symbol 
is important. 
Thank you. 
 
Comment 12 Ozgur M. Homurlu 2006-01-30 17:03:03 EST
Addition to comment #11: 
 
Following binding is also missing: 
 
4) Alt Gr-2 output should be "£" (British currency sign) 
 
These items are from the standard Turkish Q layout. 
Comment 13 Ozgur M. Homurlu 2006-01-30 17:23:37 EST
Created attachment 123890 [details]
Corrected trq.map, tested in UTF-8 setting

I have added items in comments #10 and #11 to previously attached trq.map
(attachment id 113056). I have just guessed the syntax of the file and names of
the symbols with help from google. This one seems to be complete.
Here's the diff from previous attachment:

--- trq.map.old 2006-01-31 00:19:38.000000000 +0200
+++ trq.map	2006-01-31 00:12:41.000000000 +0200
@@ -8,7 +8,7 @@
 keycode   2 = one exclam
	alt	  keycode   2 = Meta_one
	alt shift keycode   2 = Meta_exclam
-keycode   3 = two apostrophe
+keycode   3 = two apostrophe sterling
	control   keycode   3 = nul
	control shift keycode 3 = nul
	alt	  keycode   3 = Meta_two
@@ -21,7 +21,7 @@
	control   keycode   5 = Control_backslash
	alt	  keycode   5 = Meta_four
	alt shift keycode   5 = Meta_plus
-keycode   6 = five percent
+keycode   6 = five percent onehalf
	control   keycode   6 = Control_bracketright
	alt	  keycode   6 = Meta_five
	alt shift keycode   6 = Meta_percent
@@ -59,6 +59,7 @@
	altgr keycode 16 = at
 keycode  17 = w
 keycode  18 = e
+	 altgr keycode 18 = euro
 keycode  19 = r
 keycode  20 = t
 keycode  21 = y
@@ -90,7 +91,7 @@
 keycode  36 = j
 keycode  37 = k
 keycode  38 = l
-keycode  39 = +scedilla +Scedilla
+keycode  39 = +scedilla +Scedilla acute
 keycode  40 = +i +Idotabove
	control   keycode  40 = Control_g
 keycode  41 = quotedbl eacute
Comment 14 Miloslav Trmač 2006-02-01 14:41:19 EST
Thanks, I have forwarded the patch upstream as well.

(Please attach files as attachments in the future instead of including them
in the comment body.)
Comment 15 Ozgur M. Homurlu 2006-11-21 12:24:27 EST
The patch attached to this report is obsoleted by the patch in report #216710. 
Please use that patch instead. Thanks.


Note You need to log in before you can comment on or make changes to this bug.