This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 149602 - nscd, WINS, and SELinux don't mix
nscd, WINS, and SELinux don't mix
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 07:52 EST by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.25.4-10.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 12:00:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicholas Miell 2005-02-24 07:52:40 EST
Attempting to use the wins NSS module from samba-common with nscd results in the
following:

avc:  denied  { search } for  pid=29246 exe=/usr/sbin/nscd name=samba dev=dm-1
ino=2229524 scontext=root:system_r:nscd_t tcontext=system_u:object_r:samba_etc_t
tclass=dir
avc:  denied  { search } for  pid=29246 exe=/usr/sbin/nscd name=samba dev=dm-1
ino=2229524 scontext=root:system_r:nscd_t tcontext=system_u:object_r:samba_etc_t
tclass=dir
avc:  denied  { getattr } for  pid=29246 exe=/usr/sbin/nscd
path=/var/cache/samba dev=dm-1 ino=7241973 scontext=root:system_r:nscd_t
tcontext=system_u:object_r:samba_var_t tclass=dir
avc:  denied  { read } for  pid=29246 exe=/usr/sbin/nscd name=unexpected.tdb
dev=dm-1 ino=7242850 scontext=root:system_r:nscd_t tcontext=root:object_r:var_t
tclass=file
avc:  denied  { getattr } for  pid=29246 exe=/usr/sbin/nscd
path=/var/cache/samba dev=dm-1 ino=7241973 scontext=root:system_r:nscd_t
tcontext=system_u:object_r:samba_var_t tclass=dir

NSCD may also want write access to things in /var/cache/samba (it being a
cache), but it obviously doesn't get that far.

The winbind NSS module may also trigger something similar, although since that
talks to an external daemon, it'll probably require different rules.
Comment 1 Daniel Walsh 2005-02-24 10:25:27 EST
Please update to the latest policy 

yum update selinux-policy-targeted

And try it again.
Comment 2 Nicholas Miell 2005-02-24 10:52:59 EST
After updating to selinux-policy-targeted-1.21.14-2, relabeling /var/cache/samba
(mostly var_t -> samba_var_t, nothing that should matter) and restarting nscd, I
still get the same denials.

Note You need to log in before you can comment on or make changes to this bug.