Bug 149612 - parameter sizes do not match
Summary: parameter sizes do not match
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fluxconf   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-24 14:14 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 22:32:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2005-02-24 14:14:41 UTC
Description of problem:

I just tried to compile package fluxconf-0.9.7-1 from 
Redhat Fedora Extras development tree.

The compiler said

fluxconf.c(900): warning #967: conversion from "char" to "gpointer";
sizes do not match
      gtk_signal_connect(GTK_OBJECT(but), "clicked",
GTK_SIGNAL_FUNC(start_it),
prog_number);
      ^

but parameter prog_number has type char, but gtk_signal_connect accepts
type char * in the fourth parameter.

I'm not sure what the fix is for this.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Arnaud Abélard 2005-04-14 17:34:09 UTC
Andrea, are you willing to take over fluxconf too?

if not, i guess  it's not worth keeping it in extras since i'm not even sure
it's still compatible with the latest fluxbox version?





Note You need to log in before you can comment on or make changes to this bug.