Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1496196 - Mismatch priority in dialog button group [NEEDINFO]
Summary: Mismatch priority in dialog button group
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.8.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Joe Vlcek
QA Contact: Martin Kourim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 15:55 UTC by Cyril Coupel
Modified: 2018-11-13 13:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-13 13:46:54 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
jvlcek: needinfo? (ccoupel)
jvlcek: needinfo? (ccoupel)
jvlcek: needinfo? (ccoupel)


Attachments (Terms of Use)

Description Cyril Coupel 2017-09-26 15:55:30 UTC
Description of problem:
When creating a button group from catalog item and automate customization/service with the same name, the group displayed on the provisionned service on depends on the order the groups were created

Version-Release number of selected component (if applicable):
latest release

How reproducible:
 Version 5.8.1.5.20170725160636_e433fc0 


Steps to Reproduce:
1.provision a rhel service (not a heat service bz related 1496190)

2.create a button group "grp1" with a button "bt svc1" from the automate customization/service 
3.create a button group "grp1" with a button "bt dialog1" from catalog item

4. create a button group "grp2" with a button "bt dialog2" from catalog item
5. create a button group "grp2" with a button "bt svc2" from the automate customization/service 


Actual results:
on the service provided:
- button group "grp1" with "bt dialog1" (from catalog item)
- button group "grp2" with "bt svc2" (from service customization)

Expected results:
the expected result is a merge of both groups, with a priority set to the catalog item button

- button group "grp1" with "bt dialog1" and "bt svc 1" 
- button group "grp2" with "bt dialog2" and "bt svc 2" 

Additional info:

Comment 2 Chris Hale 2017-09-26 21:51:31 UTC
Can you reproduce this issue and attach a copy of the Service http REST request.  I suspect this issue might need to be reassigned to the API team and we should see what the request output currently looks like so we can make a determination.

Comment 3 Dave Johnson 2017-09-26 23:12:21 UTC
Shveta, please take a peek and assess test coverage moving forward please.

Comment 4 Shveta 2017-09-27 19:54:20 UTC
Appliance https://10.8.198.50.
Service = button_group

Need Info for Martin for http REST request.

Comment 5 Chris Hale 2017-09-27 21:40:02 UTC
I researched what is coming back from the rest API and it appears as though the API is not returning "bt dialog1" and "bt dialog2".   I am suggesting that this be reassigned to the API team to investigate.

Comment 6 Joe Vlcek 2018-08-29 21:36:04 UTC
Cyril,

I am unable to reproduce this with that latest upstream build.

Can you please try to recreate it with the current 5.10 version?

If you can reproduce it please post a private message in this BZ with the credentials to the VM where you did.

Thank you,
  JoeV

Comment 7 Joe Vlcek 2018-09-25 14:04:42 UTC
Cyril, Bump on the need info.

Comment 8 Joe Vlcek 2018-09-25 14:04:44 UTC
Cyril, Bump on the need info.

Comment 9 Joe Vlcek 2018-11-13 13:46:54 UTC
I'm closing this as WORKSFORME. I can not reproduce it and it's been in NEEDSIFO for over 2 months.
Please reopen with more information if this can be reproduced.

Thank you. JoeV


Note You need to log in before you can comment on or make changes to this bug.