Bug 1496212 - crash during startup on RaspberryPi 3B
Summary: crash during startup on RaspberryPi 3B
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 16:46 UTC by John Reiser
Modified: 2018-02-20 22:45 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 22:45:05 UTC
Type: Bug


Attachments (Terms of Use)
screen photo of console with last 60 lines of crash dump and call traceback (363.03 KB, image/jpeg)
2017-09-26 16:46 UTC, John Reiser
no flags Details

Description John Reiser 2017-09-26 16:46:05 UTC
Created attachment 1331212 [details]
screen photo of console with last 60 lines of crash dump and call traceback

Description of problem: Fedora-Minimal-27_Beta-1.3.aarch64.raw.xz booted on RaspberryPi 3B crashes during startup; on the console messages the clock reads 13 seconds.


Version-Release number of selected component (if applicable):
Fedora-Minimal-27_Beta-1.3.aarch64.raw.xz

How reproducible: every time


Steps to Reproduce:
1. boot Fedora-Minimal-27_Beta-1.3.aarch64.raw.xz on RaspberryPi 3B
2.
3.

Actual results: After the 2-second countdown to choose the only kernel, then there is a 60-second wait, probably for some disk that does not exist.  Then the monitor begins to show boot messages.  At first there are a couple dozen lines, but in a few seconds there are around 100 more in a quick batch.  Then the system hangs: no more messages and no response to keyboard, even after 5 minutes.


Expected results: No crash.  (Nice to have: no 60-second wait.)


Additional info: will attach screen photo of last 60 lines or so

Comment 1 Laura Abbott 2018-02-20 19:49:17 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  As kernel maintainers, we try to keep up with bugzilla but due the rate at which the upstream kernel project moves, bugs may be fixed without any indication to us. Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.
 
Fedora 27 has now been rebased to 4.15.3-300.f27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you experience different issues, please open a new bug report for those.

Comment 2 John Reiser 2018-02-20 22:45:05 UTC
It works for me on RaspberryPi-3B with kernel
   4.16.0-0.rc2.git0.1.fc28.aarch64 #1 SMP Mon Feb 19 14:29:53 UTC 2018
with uSDHC card made by
   xzcat Fedora-Minimal-Rawhide-20180220.n.0.aarch64.raw.xz  |  dd of=/dev/sdX bs=4M

Upon power-on, I saw a few lines on the VGA screen, ending with prompt "U-Boot> ".  Typing "boot\n" erased the screen, then boot messages appeared after about 70 seconds.  There was a "first boot" configuration dialog (using text and numbered responses) to select timezone, root password, user creation.


Note You need to log in before you can comment on or make changes to this bug.