Bug 149634 - autofs direct map mount fails
autofs direct map mount fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 12:44 EST by Jim Waldram
Modified: 2009-01-21 13:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 13:27:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Details of the problem (6.14 KB, text/plain)
2005-02-24 13:16 EST, Jim Waldram
no flags Details

  None (edit)
Description Jim Waldram 2005-02-24 12:44:40 EST
Description of problem: Autofs mounting direct map: /idl 
marten:/usr/local/idl fails


Version-Release number of selected component (if applicable):
autofs-4.1.3-67

How reproducible: fully


Steps to Reproduce:
1.service autofs restart
2.
3.
  
Actual results:syslog:
Feb 24 10:37:44 kodiak automount[19170]: starting automounter version
4.1.3-67, path = /-, maptype = yp, mapname = auto.direct
Feb 24 10:37:44 kodiak autofs: automount startup succeeded
Feb 24 10:37:44 kodiak automount[19170]: cache_ghost: entry in
yp:auto.direct not valid map format, key /idl
Feb 24 10:37:44 kodiak automount[19170]: shut down, path = /-



Expected results:


Additional info:
Comment 1 Jeff Moyer 2005-02-24 13:08:50 EST
Top-level direct mounts do not work, and are not intended to work.  There is a
work-in-progress to support this feature.  Please follow the RHEL 3 bug for
that.  Once the feature is stabilized, it will be added to RHEL 3 and 4, so long
as it isn't too intrusive a change.

Thanks,

Jeff

https://bugzilla.redhat.com/beta/show_bug.cgi?id=138363
Comment 2 Jim Waldram 2005-02-24 13:16:25 EST
Created attachment 111389 [details]
Details of the problem
Comment 3 Chris Feist 2005-02-24 15:21:43 EST

*** This bug has been marked as a duplicate of 138363 ***
Comment 11 rareigh 2007-01-09 19:04:39 EST
The bug that is is a duplicate of (138363) is not publically viewable. Please 
open it up so that others can see and track the status. (This is a feature in 
very interested in.)
Comment 12 Ian Kent 2007-01-09 20:42:23 EST
(In reply to comment #11)
> The bug that is is a duplicate of (138363) is not publically viewable. Please 
> open it up so that others can see and track the status. (This is a feature in 
> very interested in.)

I'm not sure what you need but there are a few things
that are known:

1) it can't be fixed properly in autofs v4.
2) it has been fixed in autofs v5 since the first beta
   of RHEL5.
3) we haven't had any reports this doesn't work correctly.
4) the needed kernel patches have recenty been commited
   to the RHEL4 kernel.
5) limited testing of autofs v5 in RHEL4 is underway.
6) it's not yet clear how autofs v5 will be made
   available for RHEL4.

Ian
Comment 13 rareigh 2007-01-10 11:42:38 EST
I did get direct automounts to work after seeting the DISABLE_DIRECT=0 
variable in /etc/sysconfig/autofs.

The issue I'm interested in is the lack of support for top-level direct 
mounts. I have some legacy pathnames which are top-level directories and that 
cannot be changed. We're also in the process of chaning my whole site from 
hard mounts to autofs. If I can't get this feature to work in RHEL4, I'll have 
to use some workaround (like symlinking to a non-direct mount point).
Comment 14 Ian Kent 2007-01-10 12:15:38 EST
(In reply to comment #13)
> I did get direct automounts to work after seeting the DISABLE_DIRECT=0 
> variable in /etc/sysconfig/autofs.
> 
> The issue I'm interested in is the lack of support for top-level direct 
> mounts. I have some legacy pathnames which are top-level directories and that 
> cannot be changed. We're also in the process of chaning my whole site from 
> hard mounts to autofs. If I can't get this feature to work in RHEL4, I'll have 
> to use some workaround (like symlinking to a non-direct mount point).

You will need to use autofs v5 for the top level mount support.

The only thing that's needed to be able to use v5 is the kernel
update which will be in the RHEL4 U5 kernel.

As I said how we deploy the package in RHEL4 is not clear but we
should be able to make it available somehow for those that who
need it. The problem of course is that we already have an autofs
in RHEL4.

Ian
Comment 19 Jeff Moyer 2009-01-21 13:27:46 EST
The autofs5 package was added to RHEL 4, and it has support for top-level direct mounts.  Autofs version 5 is also the default in RHEL 5.

Note You need to log in before you can comment on or make changes to this bug.