Bug 149656 - NetworkManager tries to use non-existant wireless
NetworkManager tries to use non-existant wireless
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 16:18 EST by J.B. Nicholson-Owens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 12:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.B. Nicholson-Owens 2005-02-24 16:18:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050222 Firefox/1.0+

Description of problem:
My desktop machine only has an ethernet connection to the network.  There is no wireless hardware on the machine.  I run NetworkManager just to see what it will do.

When I right-click on the tray icon (which currently shows me an ethernet cable and jack), I get a menu with one choice (which is odd in itself):

  [checked] Wired Network


Version-Release number of selected component (if applicable):
NetworkManager-0.3.3-1.cvs20050119.2.fc3

How reproducible:
Always

Steps to Reproduce:
1. Log in.  See the Network Manager icon program start up and indicate the connection is the wired connection.
2. Select the icon with the right mouse button, and uncheck the sole menu choice ("Wired Network").
3. Watch the program's icon indicate it is looking for a wireless connection.

Actual Results:  If I try to uncheck it, NM shows me two circles and a pair of swooshing symbols that make it look like it's searching for a wireless connection.  I don't understand why it would ever do this when there is no wireless hardware in the machine.

Expected Results:  There should have been no menu or nothing should have happened when I tried to uncheck the menu choice.  I admit it's odd to run Network Manager when you only have one network connection, but I like the icon to tell me how I'm accessing the network.

Additional info:
Comment 1 Dan Williams 2005-05-16 16:16:04 EDT
Its actually attempting to reconnect to the wired network and going through the
DHCP transaction again...  do more recent versions of NetworkManager fix this at
all?  (ie, 0.3.4 and later in fc3-updates)
Comment 2 J.B. Nicholson-Owens 2005-05-17 01:22:26 EDT
I've got NetworkManager Applet 0.3.4.

Now I see something differently odd: The menu offers "Pause Wireless Scanning"
suggesting that it is scanning for wireless networks.

How it is doing this with no wireless hardware in the machine, I don't
understand.  Nor do I understand why it is even trying.  Nor do I understand why
it can't see that there is no reasonable hardware with which to do this job.

I can pause wireless scanning and then I'm offered the chance to "Resume
Wireless Scanning".  Again, same questions, but this does not disturb my wired
connection -- the wired connection keeps working regardless of what the menu
says, and the connection icon stays on the wired connection (no swirling circles
indicating a search is proceeding), so that's one big step forward.

Thanks!
Comment 3 J.B. Nicholson-Owens 2006-03-22 12:52:27 EST
The most recent NetworkManager (0.6.0) in FC5 doesn't have this problem.  This
bug should be closed.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.