Bug 149662 - warning for deleting a fence device with many dependancies only shows one of them
Summary: warning for deleting a fence device with many dependancies only shows one of ...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster   
(Show other bugs)
Version: 4
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-24 21:54 UTC by Corey Marthaler
Modified: 2009-04-16 20:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 22:58:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2005-02-24 21:54:45 UTC
Description of problem:
I attempted to delete a fence device which was being used by all the
nodes in the cluster and the warning which popped up said it only had
only one dependancy. It took me a second to realize that the warning
message was really a scroll box full of all the nodes dependant on
this device, but only displayed the one. A simple text list would be
far more intuitive since it would display all of them and since
nothing in there is selectable anyway.

Comment 1 Jim Parsons 2005-03-01 17:51:37 UTC
will fix

Comment 2 Jim Parsons 2005-03-28 11:24:28 UTC
Fixed in 0.9.17-1.0

Comment 3 Corey Marthaler 2005-04-18 18:36:47 UTC
It's still just a scroll box, which displays 5 items (nodes). So when I have 6+
nodes in my cluster, I don't see all the dependancies when deleting the fence
device. This is a pretty low priority request, but I don't think it'd be too
hard to do it right.

Comment 4 Jim Parsons 2005-04-28 14:08:13 UTC
The reason to use a scroll box, is when the size of text or a list to be
displayed is variable.

From the GNOME HIG:
"Often an object (such as a document or a list) will not be fit within the
confines of its viewer control. In these cases a scrollbar can be affixed to the
viewer control. The scrollbar alters which part of the object is currently
visible inside the viewer control: it slides the view across the object in one
axis (horizontal or vertical)."

I do not believe that setting the size of the display area dependent on the size
of the list to be displayed, as on a 50+ node cluster, the display area will
grow beyond the height of the screen for typical resolutions. I am setting the
size of the display area larger in closing this bug again, but strongly believe
that scrollbars is the correct solution here.

Comment 5 Jim Parsons 2005-04-28 14:09:00 UTC
BTW, expanded display area is in 0.9.42

Comment 6 Corey Marthaler 2005-04-28 22:58:49 UTC
fix verified.


Note You need to log in before you can comment on or make changes to this bug.