Bug 149680 - RAID1 not recognized by freshly-installed FC3 on Dell Precision Workstation 670n
RAID1 not recognized by freshly-installed FC3 on Dell Precision Workstation 670n
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 19:53 EST by Erich Schwarz
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 23:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Schwarz 2005-02-24 19:53:33 EST
Description of problem: Installing FC3 on a Dell Precision Workstation
670n yields an apparently working installation, but one in which both
SATA hard drives are being used separately without RAID as a single
logical volume.  This happens even after RAID1 is set in the BIOS.


Version-Release number of selected component (if applicable):


How reproducible:  I've only tried this once and won't do it again
unless I know of some way to avoid it; the installation is for a
production server which would be time-consuming to reinstall.


Steps to Reproduce:
1. Reformat two SATA hard drives with BIOS; set to RAID1 with BIOS.
2. Do standard full installation of FC3 from CDs using automatic
partioning.
  
Actual results: Be confounded by seeing 2x drives with "df -h".Be
confounded by seeing 2x drives with "df -h".

Expected results: Run "df -h" and see just one drive, implying that
RAID1 is working.

Additional info: Other web sites seem to indicate that this is due to
an inability of the FC3 kernel to recognize "software RAID
controllers", whatever that means.  If so, it would be wonderful if
this could be fixed for Fedora Core 4.
Comment 1 Dave Jones 2005-02-24 23:32:02 EST
it means that they use something similar to Linux's software raid,
however in a proprietary format.   Unless someone reverse engineers
it, and writes a driver to remap the blocks, you're out of luck.

Note You need to log in before you can comment on or make changes to this bug.