Bug 1496895 - Opengl SDL2 applications crash with coredump under Xorg - arguments to dbus_type_is_basic() were incorrect
Summary: Opengl SDL2 applications crash with coredump under Xorg - arguments to dbus_t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL2
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1497483 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 18:03 UTC by mjvaisane
Modified: 2017-10-10 19:29 UTC (History)
5 users (show)

Fixed In Version: SDL2-2.0.6-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-10 19:29:35 UTC
Type: Bug


Attachments (Terms of Use)

Description mjvaisane 2017-09-28 18:03:38 UTC
Description of problem:
Any graphical application compiled against SDL2 crashes in startup (coredump) with following error:
dbus[4627]: arguments to dbus_type_is_basic() were incorrect, assertion "dbus_type_is_valid (typecode) || typecode == DBUS_TYPE_INVALID" failed in file ../../dbus/dbus-signature.c line 323.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)

Version-Release number of selected component (if applicable):
SDL2-devel-2.0.6-1.fc27.x86_64
SDL2-2.0.6-1.fc27.x86_64

How reproducible:
Start any opengl application using SDL2

Steps to Reproduce:
1. Install neverball
2. try to run it

or:
1. Download source code of very basic opengl SDL2 app from here: 
https://gist.github.com/dirkk0/cad259e6a3965abb4178
2. Install dependencies (g++, SDL2-devel, freeglut-devel)
3. compile app with: 
g++ main.cpp -I /usr/include/SDL2/ -lSDL2  -lGL
4. run app with:
./a.out

Actual results:
Application crashes with coredump

Expected results:
Application should run

Additional info:
I have tried compiling several SDL2 based apps and all of them are crashing with exactly the same error. For example vice 3.0 (use --with-sdlui2) or fs-uae both are having same problem.
Also, neverball installed from Fedora repos seems to crash with same error, so this seems to be problem in all opengl SDL2 apps.
Fedora 27, latest updates installed as in September 28th.

Comment 1 mjvaisane 2017-09-29 03:11:59 UTC
I have laptop with Intel + Nvidia GPU. Result seems to be same regardless which driver is in use (tested Nvidia driver from negativo repo and pure opensource one).

Is this more related to UDEV than SDL2?

Comment 2 Igor Gnatenko 2017-09-29 07:39:10 UTC
interesting that I can't reproduce this on rawhide (which has same version of SDL2)....

Comment 3 mjvaisane 2017-09-29 11:12:14 UTC
Can I produce more logs? This is new Fedora 27 installation (beta compose 1.3).

Comment 4 mjvaisane 2017-09-29 12:11:57 UTC
OK, I just did clean install of Fedora 27 (beta compose 1.3), under KVM virtual machine, using Vmware virtual GPU.
Installed neverball, and it worked fine.
Then, I upgraded Fedora to newest level with dnf upgrade.
Reboot, and after reboot, I got same error and coredump.

Comment 5 Ozkan Sezer 2017-09-30 11:39:58 UTC
This is https://bugzilla.libsdl.org/show_bug.cgi?id=3854 and
it can be reproduced on F20/x86_64 too. I first thought that
it is related to IME, but unset'ing XMODIFIERS does not seem
to remove the issue.

Comment 6 Igor Gnatenko 2017-10-01 07:47:05 UTC
*** Bug 1497483 has been marked as a duplicate of this bug. ***

Comment 7 Ozkan Sezer 2017-10-03 09:04:42 UTC
A fix is suggested at https://bugzilla.libsdl.org/show_bug.cgi?id=3854#c7

Comment 8 Ozkan Sezer 2017-10-05 20:58:12 UTC
This is fixed by http://hg.libsdl.org/SDL/rev/dc7245e3d1f2

Comment 9 Fedora Update System 2017-10-05 21:18:38 UTC
SDL2-2.0.6-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-567bca6531

Comment 10 Igor Gnatenko 2017-10-05 21:19:37 UTC
(In reply to Ozkan Sezer from comment #8)
> This is fixed by http://hg.libsdl.org/SDL/rev/dc7245e3d1f2

Thanks a lot and sorry for delay!

Comment 11 Fedora Update System 2017-10-06 22:25:36 UTC
SDL2-2.0.6-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-567bca6531

Comment 12 Fedora Update System 2017-10-10 19:29:35 UTC
SDL2-2.0.6-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.