Bug 14972 - autofs error message (insmod) at startup
autofs error message (insmod) at startup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Winston rc1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-01 11:23 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 10:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-08-01 11:23:30 EDT
When starting a Pinestripe system (a complete install - so nothing should
be missing) I do get the error message:

insmod: insmod: insmod autofs failed

(right before the "Mounting other filesystems" message)
Comment 1 Bill Nottingham 2000-08-01 11:29:48 EDT
What's your /etc/fstab look like?
Comment 2 Michael Redinger 2000-08-01 11:35:52 EDT
Nothing special with this. Generated by installer.

LABEL=/		/		ext2	defaults		1 1
LABEL=/boot	/boot		ext2	defaults		1 2
/dev/cdrom	/mnt/cdrom	iso9660	noauto,owner,ro	0 0
/dev/fd0		/mnt/floppy	auto	noauto,owner	0 0
none		/proc		proc	defaults		0 0
none		/dev/pts		devpts	gid=5,mode=620	0 0
/dev/hda6	swap		swap	defaults		0 0
Comment 3 Nalin Dahyabhai 2000-08-02 18:36:30 EDT
This looks like some strange concurrency problem in the kernel or modutils --
the kernel attempts to autoload the autofs.o kernel module, and if you start
with multiple automounted directories, multiple attempts are kicked off at
once.  As part of another bug fix, syslog is now being started before autofs, so
this message is being redirected to a log.
Comment 4 Glen Foster 2000-08-04 10:45:33 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 5 Nalin Dahyabhai 2000-08-04 15:03:58 EDT
Workaround added to autofs-4.0.0pre7-23 and later.

Note You need to log in before you can comment on or make changes to this bug.