Bug 149729 - iscsi kernel module and iscsi-initiator-utils missing in RHEL4
iscsi kernel module and iscsi-initiator-utils missing in RHEL4
Status: CLOSED DUPLICATE of bug 107089
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-25 15:08 EST by Josh Hildebrand
Modified: 2007-11-30 17:07 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 16:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Hildebrand 2005-02-25 15:08:41 EST
Description of problem:
iscsi kernel module and iscsi-initiator-utils are missing in RHEL4.
They have been available in RHEL3 since 12/22/04.
Comment 1 Josh Hildebrand 2005-03-01 17:57:48 EST
Just curious if there is an ETA for iscsi support in RHEL4.  Was there a 
particular reason it was removed?  We have a specific need for it.  I'd rather 
not go back to using the 3rd party version.
Comment 2 Tom Coughlan 2005-03-02 13:51:02 EST
The iSCSI initiator in RHEL 3 is based on the Cisco SourceForge driver. 

http://sourceforge.net/projects/linux-iscsi/

This driver has not been entirely ported and stablized on the 2.6 kernel yet. As
soon as an iSCSI initiator driver is accepted into the 2.6 kernel we will
consider shipping it in RHEL 4. The earliest this will occur is in U2. 
Comment 4 Trond Eivind Glomsrød 2005-06-24 03:16:54 EDT
FWIW, a version patched as described on the mailing list seems to work well on
RHEL4 U1. 
Comment 5 Brian Long 2005-06-24 10:52:41 EDT
Tom, have the developers of the linux-iscsi driver started working with upstream
kernel maintainers regarding this integration?  Do you expect they'll make the
U2 cut-off or will this slip even further?  Thanks.
Comment 6 thewolf 2005-06-25 06:14:51 EDT
We are waiting got the iSCSI initiator for RHEL4 too.
Is there any ETA for it?

Thanks.
Comment 7 Tom Coughlan 2005-06-25 11:45:38 EDT
The 4.x branch of the Cisco/SourceForge linux-iscsi project is planned for RHEL
4 U2. It will be in the U2 beta. If you are able to do some meaningful RHEL 4
testing before the beta is released, please contact mchristi@redhat.com by mail
for a preview.  
Comment 8 Brian Long 2005-10-06 10:21:38 EDT
This bug should have been resolved as part of the RHEL 4 U2 release yesterday.
Comment 9 Rob Kenna 2005-10-06 16:52:40 EDT
Yes, indeed.  This is actually a duplicate of 107089 and is available as of Oct
5 on RHEL 4 Update 2.

*** This bug has been marked as a duplicate of 107089 ***

Note You need to log in before you can comment on or make changes to this bug.