Bug 149758 - kernel-2.6.10-1.1153_FC4 unbootable - "Unknown symbol"
kernel-2.6.10-1.1153_FC4 unbootable - "Unknown symbol"
Status: CLOSED DUPLICATE of bug 150150
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 149759 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-25 17:31 EST by Michal Jaegermann
Modified: 2015-01-04 17:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 19:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-02-25 17:31:28 EST
Description of problem:

An attempt to boot kernel-2.6.10-1.1153_FC4 ends up with

ext3.ko:  Unknown symbol print_tainted

from initrd; but before that there is bunch of complaints
of the same sort from sata_via module.  All of them about
ata_<this> or ata_<that>.  The top of a pretty extensive list
scrolls of a screen but ata_port_start and ata_device_add
are on this list. 'lib/libata.ko' is on the listing of
a correspondign initrd so at this moment is not clear what
is wrong beyon that remaking initrd does not help.

Earlier kernels do boot and 'depmod -ae 2.6.10-1.1153_FC4'
does not produce any complaints.

As for now I do not have i686 kernel yet to check if it is
afflicted too.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.1153_FC4 

How reproducible:
100%
Comment 1 Michal Jaegermann 2005-02-25 19:18:50 EST
'depmod -ae ...' on x86 produces around 180 "unknown symbol"
warnings so it is not likely that this kernel boots either.

I am not sure what I did previously on x86_64 to get a quiet
depmod run.  I tried that again and this time I ended up with 141
complaints.
Comment 2 Alexandre Oliva 2005-02-26 03:03:32 EST
*** Bug 149759 has been marked as a duplicate of this bug. ***
Comment 3 Alexandre Oliva 2005-02-26 03:05:42 EST
Same here, it fails to boot because device mapper and scsi modules are
missing symbols.  I tried the i686 UP kernel.  I could try x86_64 UP
as well, but since that's the original report, I guess I won't even
bother...
Comment 4 Bojan Smojver 2005-02-27 19:02:50 EST
I'm seeing this with 2.6.10-1.1155_FC4 kernel in relation to in6addr_loopback
symbol. Some of the GFS modules (lock_gulm) want it but can't find it:

-----------------------------------
[root@xen1 ipv6]# modprobe lock_gulm
lock_gulm: Unknown symbol in6addr_loopback
FATAL: Error inserting lock_gulm
(/lib/modules/2.6.10-1.1155_FC4xenU/kernel/fs/gfs_locking/lock_gulm/lock_gulm.ko):
Unknown symbol in module, or unknown parameter (see dmesg)
-----------------------------------

Inspection if ipv6.ko module gives:

-----------------------------------
[root@xen1 ipv6]# nm ipv6.ko  | grep in6addr_loopback
00000024 R in6addr_loopback
-----------------------------------

Same thing on FC3 (2.6.10-1.766_FC3) gives:

-----------------------------------
[root@itp800 ipv6]# nm ipv6.ko  | grep in6addr_loopback
97abb28c A __crc_in6addr_loopback
00000034 R in6addr_loopback
00000060 r __kcrctab_in6addr_loopback
000001a3 r __kstrtab_in6addr_loopback
000000c0 r __ksymtab_in6addr_loopback
-----------------------------------

Not sure if the above falls into the same category as what other people reported
in this bug, but if it does, I hope it's useful.
Comment 5 Bojan Smojver 2005-02-27 19:49:52 EST
BTW, this seems to be the problem even when loading lock_gulm in xen0 kernel,
not just xenU.
Comment 6 Bojan Smojver 2005-03-02 19:09:23 EST
Installation of 1162 gives:

---------------------------
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/snd-seq-midi-emul.
ko needs unknown symbol alsa_seq_midi_emul_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/snd-seq-midi-emul.
ko needs unknown symbol alsa_seq_midi_emul_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/snd-seq-virmidi.ko
 needs unknown symbol alsa_virmidi_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/snd-seq-virmidi.ko
 needs unknown symbol alsa_virmidi_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-i
w.ko needs unknown symbol alsa_ainstr_iw_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-i
w.ko needs unknown symbol alsa_ainstr_iw_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-s
imple.ko needs unknown symbol alsa_ainstr_simple_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-s
imple.ko needs unknown symbol alsa_ainstr_simple_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-g
f1.ko needs unknown symbol alsa_ainstr_gf1_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-g
f1.ko needs unknown symbol alsa_ainstr_gf1_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-f
m.ko needs unknown symbol alsa_ainstr_fm_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/instr/snd-ainstr-f
m.ko needs unknown symbol alsa_ainstr_fm_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/snd-seq-instr.ko n
eeds unknown symbol alsa_seq_instr_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/core/seq/snd-seq-instr.ko n
eeds unknown symbol alsa_seq_instr_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/opl4/snd-opl4-lib.k
o needs unknown symbol alsa_opl4_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/opl4/snd-opl4-lib.k
o needs unknown symbol alsa_opl4_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/mpu401/snd-mpu401-u
art.ko needs unknown symbol alsa_mpu401_uart_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/mpu401/snd-mpu401-u
art.ko needs unknown symbol alsa_mpu401_uart_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/vx/snd-vx-lib.ko ne
eds unknown symbol alsa_vx_core_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/vx/snd-vx-lib.ko ne
eds unknown symbol alsa_vx_core_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/opl3/snd-opl3-lib.k
o needs unknown symbol alsa_opl3_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/drivers/opl3/snd-opl3-lib.k
o needs unknown symbol alsa_opl3_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb8-dsp.ko needs
 unknown symbol alsa_sb8_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb8-dsp.ko needs
 unknown symbol alsa_sb8_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb-common.ko nee
ds unknown symbol alsa_sb_common_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb-common.ko nee
ds unknown symbol alsa_sb_common_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb16-csp.ko need
s unknown symbol alsa_sb_csp_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb16-csp.ko need
s unknown symbol alsa_sb_csp_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb16-dsp.ko need
s unknown symbol alsa_sb16_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/sb/snd-sb16-dsp.ko need
s unknown symbol alsa_sb16_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/cs423x/snd-cs4231-lib.k
o needs unknown symbol alsa_cs4231_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/cs423x/snd-cs4231-lib.k
o needs unknown symbol alsa_cs4231_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/cs423x/snd-cs4236-lib.k
o needs unknown symbol alsa_cs4236_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/cs423x/snd-cs4236-lib.k
o needs unknown symbol alsa_cs4236_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/ad1848/snd-ad1848-lib.k
o needs unknown symbol alsa_ad1848_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/ad1848/snd-ad1848-lib.k
o needs unknown symbol alsa_ad1848_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/es1688/snd-es1688-lib.k
o needs unknown symbol alsa_es1688_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/es1688/snd-es1688-lib.k
o needs unknown symbol alsa_es1688_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/gus/snd-gus-lib.ko need
s unknown symbol alsa_gus_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/gus/snd-gus-lib.ko need
s unknown symbol alsa_gus_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/ad1816a/snd-ad1816a-lib
.ko needs unknown symbol alsa_ad1816a_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/isa/ad1816a/snd-ad1816a-lib
.ko needs unknown symbol alsa_ad1816a_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/pci/ac97/snd-ac97-codec.ko 
needs unknown symbol alsa_ac97_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/pci/ac97/snd-ac97-codec.ko 
needs unknown symbol alsa_ac97_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/pci/ac97/snd-ak4531-codec.k
o needs unknown symbol alsa_ak4531_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/pci/ac97/snd-ak4531-codec.k
o needs unknown symbol alsa_ak4531_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/pci/ice1712/snd-ice17xx-ak4
xxx.ko needs unknown symbol alsa_ice1712_akm4xxx_module_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/pci/ice1712/snd-ice17xx-ak4
xxx.ko needs unknown symbol alsa_ice1712_akm4xxx_module_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/other/snd-tea575x-tuner
.ko needs unknown symbol alsa_tea575x_module_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/other/snd-tea575x-tuner
.ko needs unknown symbol alsa_tea575x_module_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/other/snd-ak4xxx-adda.k
o needs unknown symbol alsa_akm4xxx_module_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/other/snd-ak4xxx-adda.k
o needs unknown symbol alsa_akm4xxx_module_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/snd-cs8427.ko needs unk
nown symbol alsa_cs8427_module_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/snd-cs8427.ko needs unk
nown symbol alsa_cs8427_module_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/snd-tea6330t.ko needs u
nknown symbol alsa_tea6330t_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/snd-tea6330t.ko needs u
nknown symbol alsa_tea6330t_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/snd-i2c.ko needs unknow
n symbol alsa_i2c_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/i2c/snd-i2c.ko needs unknow
n symbol alsa_i2c_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/synth/snd-util-mem.ko needs
 unknown symbol alsa_util_mem_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/synth/snd-util-mem.ko needs
 unknown symbol alsa_util_mem_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/synth/emux/snd-emux-synth.k
o needs unknown symbol alsa_emux_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/sound/synth/emux/snd-emux-synth.k
o needs unknown symbol alsa_emux_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/net/wireless/orinoco.ko n
eeds unknown symbol exit_orinoco
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/net/wireless/hermes.ko ne
eds unknown symbol exit_hermes
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/net/wireless/hermes.ko ne
eds unknown symbol init_hermes
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/md/xor.ko needs unknown s
ymbol xor_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/scsi/qlogicfas408.ko need
s unknown symbol qlogicfas408_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/scsi/qlogicfas408.ko need
s unknown symbol qlogicfas408_init
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/media/common/saa7146_vv.k
o needs unknown symbol saa7146_vv_cleanup_module
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/media/common/saa7146_vv.k
o needs unknown symbol saa7146_vv_init_module
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/media/common/saa7146.ko n
eeds unknown symbol saa7146_cleanup_module
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/isdn/hardware/avm/b1.ko n
eeds unknown symbol b1_exit
WARNING: /lib/modules/2.6.10-1.1162_FC4/kernel/drivers/usb/atm/usb_atm.ko needs 
unknown symbol udsl_usb_exit
---------------------------
Comment 7 Dave Jones 2005-03-02 19:11:19 EST

*** This bug has been marked as a duplicate of 150150 ***

Note You need to log in before you can comment on or make changes to this bug.