This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 149792 - udev dos not set the right permissions for sound devices
udev dos not set the right permissions for sound devices
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-26 18:58 EST by Florian Mayer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 05:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian Mayer 2005-02-26 18:58:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
I changed the permissions for the audio devices (/dev/dsp, /dev/mixer,
/dev/snd/* ...) in /etc/udev/permissions.d/50-udev.permissions to 0666
to get audio playback working as a normal user. But udev still creates
the devices with 0600. 
The lines in the permissions-file look like this:
...
# audio devices
dsp*:root:root:0666
audio*:root:root:0666
midi*:root:root:0666
mixer*:root:root:0666
sequencer*:root:root:0666
sound/*:root:root:0666
snd/*:root:root:0666
beep:root:root:0666
admm*:root:root:0666
adsp*:root:root:0666
aload*:root:root:0666
amidi*:root:root:0666
dmfm*:root:root:0666
dmmidi*:root:root:0666
sndstat:root:root:0666
...
A lsmod produces the following output:
....
snd_ens1371            27937  0
snd_rawmidi            25953  1 snd_ens1371
snd_seq_device          8525  1 snd_rawmidi
snd_ac97_codec         67489  1 snd_ens1371
snd_pcm_oss            47989  0
snd_mixer_oss          17089  1 snd_pcm_oss
snd_pcm                93001  3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
snd_timer              29125  1 snd_pcm
snd                    52645  8
snd_ens1371,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10017  1 snd
snd_page_alloc          9541  1 snd_pcm
gameport                4929  1 snd_ens1371
....
The onboard ac97 codec is not used due to its poor sound qualities. As
root or after changing the permissions manually to 0666 as normal user
audio playback is possible.

Regards
Florian Mayer

Version-Release number of selected component (if applicable):
udev-039-10.FC3.6 kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1.change permissions file as seen in description 
2.reboot
3.ls -l /dev/dsp /dev/mixer /dev/snd/* will show 0600 as permission.
    

Actual Results:  Wrong permissions

Expected Results:  the permissions as written in the permissions file

Additional info:
Comment 1 Harald Hoyer 2005-02-28 05:34:20 EST
this is because pam_console sets the permissions according to :
/etc/security/console.perms

Note You need to log in before you can comment on or make changes to this bug.