Bug 149802 - Amiga partition support inconsistent
Amiga partition support inconsistent
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-27 04:27 EST by Eike M. Lang
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 21:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eike M. Lang 2005-02-27 04:27:04 EST
Description of problem:

The default kernel configuration includes support for the Amiga
FastFileSystem (affs) as a module, but does not include support for
Amiga-style partition tables. This does not make a whole lot of sense.
The chances of encountering a drive that has a PC-style partition
table with Amiga partitions on it are very slim indeed.

My suggestion would be to either add amiga partition table support
(preferred) or to remove the affs module for consistency reasons
because in order to properly use it the kernel will need a recompile
anyways.

Version-Release number of selected component (if applicable):

Any kernel (standard and updates) released for FC3.
Comment 1 Dave Jones 2005-07-15 14:18:12 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Dave Jones 2005-08-04 14:48:59 EDT
fixed in CVS. Will be in next builds.

Note You need to log in before you can comment on or make changes to this bug.