Bug 149851 - (IT_67012) clusvcmgrd (svclib_filesystem) kills too many processes
clusvcmgrd (svclib_filesystem) kills too many processes
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 05:43 EST by Bastien Nocera
Modified: 2009-04-16 16:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-03 16:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-02-28 05:43:55 EST
clusvcmgrd kills too many processes when code wrongly matches too many
entries (/usr/lib/clumanager/services/svclib_filesystem:182). For
example, processes accessing:
/var/spool/mail
/var/spool/mail_bak

Both will be killed when matching /var/spool/mail:
          done < <(lsof -b 2>/dev/null | \
                    grep "$mp" | \
                    awk '{print $1,$2,$3}' | \
                    sort -u -k 1,3)

Patch from installed (by uthomas@redhat.com):

--- ./usr/lib/clumanager/services/svclib_filesystem.old 2005-02-25
17:09:43.000000000 +0000
+++ ./usr/lib/clumanager/services/svclib_filesystem     2005-02-28
09:23:07.508283144 +0000
@@ -181,7 +181,7 @@
               kill -TERM $pid
             fi
           done < <(lsof -b 2>/dev/null | \
-                    grep "$mp" | \
+                    grep -E "$mp(/.*|)\$" | \
                    awk '{print $1,$2,$3}' | \
                    sort -u -k 1,3)
         elif [ -n "$have_fuser" ]; then
Comment 2 Lon Hohberger 2005-02-28 10:50:26 EST
Patch looks clean.
Comment 3 Lon Hohberger 2005-02-28 10:51:07 EST
Accepting bug.
Comment 5 Lon Hohberger 2005-02-28 11:07:03 EST
Setting to RHCS.
Comment 7 Lon Hohberger 2005-03-02 01:32:40 EST
in 1.2.26 for testing
Comment 10 Lon Hohberger 2005-05-03 16:31:25 EDT
Works for me on the beta bits.
Comment 11 Jay Turner 2005-05-25 12:41:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-047.html

Note You need to log in before you can comment on or make changes to this bug.