Bug 149860 - Interface up because of "onboot=no"
Interface up because of "onboot=no"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 09:24 EST by Falko Pilz
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 16:26:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Falko Pilz 2005-02-28 09:24:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Hello,

we has rebooted the whole s390 LPAR on saturday, for that Linux (I
talking about) it should be the same as an "init 6".

After this server came up, he has the interface eth0:0 up, because of
that "onboot=no" was in /etc/sysconfig/network-scripts/ifcfg-eht0:0.
The matter is, that this interface only should be used when another
server wends down (manual failover). This causes a duplicate
IP-Address and there for a lot of trouble with false public ssh - keys
and so on.
At first I should think nobody was able to bring this interface up by
hand, because at the bootup I was alone and I never touched this
system directly. My application admin says that the trouble starts
directly after the boot.

Regards 

Falko

Version-Release number of selected component (if applicable):
1.60-20

How reproducible:
Always

Steps to Reproduce:
1. service network restart    

Actual Results:  eth0:0 is up and has an IP still exists

Expected Results:  eth0:0 should be waiting for activation

Additional info:

/etc/sysconfig/networking/profiles/default is empty
Comment 4 Radek Vokal 2005-03-30 07:59:52 EST
Reproduced here, I've got virtual interface eth0:2, ifcfg-eth0:2 contains 

GATEWAY=192.168.1.1
TYPE=Ethernet
DEVICE=eth0:2
HWADDR=00:0f:1f:78:0d:18
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=192.168.1.99
IPV6INIT=no
ONBOOT=no
^^^^^^^^^
USERCTL=no
PEERDNS=yes

ifdown eth0:2 stops the interface, but after `service network restart` the
interface is up again. This looks to me like a wrong parsing of the
configuration file, assigning to initscripts.
Comment 6 Bill Nottingham 2005-03-30 16:26:05 EST
For aliases, ONPARENT=(yes|no) is used.

Note You need to log in before you can comment on or make changes to this bug.