Bug 149895 - segfault on mouse out
segfault on mouse out
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 12:35 EST by Harald Hoyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 09:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2005-02-28 12:35:04 EST
http://www.wow-europe.com/de/
- click on a picture in the news section
- move mouse out and in the window

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208944960 (LWP 24881)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x007d2e71 in nsWindow::GetRootAccessible (this=0x9f9efa8,
    aAccessible=0x7ea908) at ../../../dist/include/xpcom/nsCOMPtr.h:1211
#2  0x007d3d16 in nsWindow::DispatchDeactivateEvent (this=0x9f9efa8)
    at ../../../dist/include/xpcom/nsCOMPtr.h:1211
#3  0x007d3e57 in nsWindow::OnContainerFocusOutEvent (this=0x9d87170,
    aWidget=0xa06c4b0, aEvent=0x97f6680) at nsWindow.cpp:1530
#4  0x007d3eb6 in focus_out_event_cb (widget=0xa06c4b0, event=0x97f6680)
    at nsWindow.cpp:3304
#5  0x0033c48b in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#6  0x00d58e57 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#7  0x00d6cbee in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#8  0x00d6d9bf in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#9  0x00d6df34 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#10 0x0041ece8 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x0042decd in gtk_window_propagate_key_event ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x004323af in gtk_window_activate_key () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x004324ec in gtk_window_activate_key () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x0033c48b in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#15 0x00d590ec in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#16 0x00d58e57 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#17 0x00d6c783 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#18 0x00d6d9bf in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#19 0x00d6df34 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#20 0x0041ece8 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x0033afdb in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x001ef382 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#23 0x00cf01e8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0x00cf1a08 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#25 0x00cf1d2f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#26 0x0033a2de in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x007d4b9a in nsAppShell::Run (this=0x9578e58) at nsAppShell.cpp:142
#28 0x00768c9d in nsAppShellService::Run (this=0xbffdd070)
    at ../../../dist/include/xpcom/nsCOMPtr.h:710
#29 0x0804f536 in xre_main (argc=1, argv=0xbffde914, aAppData=0x8056014)
    at ../../dist/include/xpcom/nsCOMPtr.h:710
#30 0x0804b28d in main (argc=1, argv=0xbffde914) at nsBrowserApp.cpp:58
#31 0x00aeada8 in __libc_start_main () from /lib/tls/libc.so.6
#32 0x0804b1e5 in _start ()
Comment 1 Harald Hoyer 2005-02-28 12:39:31 EST
News Section: Events zum Start
javascript:popUpOmega('/shared/wow-com/images/news/2005-02/retail01.jpg',450,600,'')
Comment 2 Harald Hoyer 2005-02-28 12:40:20 EST
100% reproducible
$ rpm -q firefox
firefox-1.0.1-2
Comment 3 Martin Stransky 2007-04-13 09:03:11 EDT
I'm unable to reproduce. Please reopen if it still fails for you.

Note You need to log in before you can comment on or make changes to this bug.