Red Hat Bugzilla – Bug 149897
Make "Add..." button names consistent
Last modified: 2015-04-19 20:46:49 EDT
Description of problem:
For the âAdd...â buttons in âCluster Nodesâ, âFence Devicesâ,
âFailover Domainsâ, and in the Fence Configuration dialog box (Cluster
-> Cluster Nodes -> <node name> -> Manage Fencing For This Node),
either include or exclude the article âaâ for consistency. For
example, in âCluster Nodesâ, the âAdd...â button is âAdd a Cluster
Nodeâ; in âFence Devicesâ, the âAdd...â button is âAdd Fence Deviceâ.
Version-Release number of selected component (if applicable):
Fixed in 0.9.12
We now have:
"Add a Cluster Node"
"Add a Fence Device"
"Add a Failover Domain"
"Create a Resource"
"Create a Service"
Do we want consistency wrt Add/Create as well?
Changed 'Add a failover domain' to 'Create a failover domain', with the policy
being nodes and fence devices are actual things, so they cannot be created, but
resources, services, and failover domains are abstract software concepts that
CAN be created by the interface.
Fixed in 0.9.17-1.0
the "Create a Failover Domain" uses the "Add..." icon, we're almost consistent
but not just yet.
Fixed in 0.9.36
fix verified in 0.9.36.