Bug 149899 - gdm should call setegid and seteuid before calling g_file_test on the user's home directory
Summary: gdm should call setegid and seteuid before calling g_file_test on the user's ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdm   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 137160
TreeView+ depends on / blocked
 
Reported: 2005-02-28 17:51 UTC by Ray Strode [halfline]
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-151
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 12:11:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:151 normal SHIPPED_LIVE gdm bug fix update 2005-06-09 04:00:00 UTC

Description Ray Strode [halfline] 2005-02-28 17:51:09 UTC
Currently gdm tries to ensure that the user's home directory exists
before initiating the login session.  This causes problems in
situations where root doesn't have permission to know about the
existance of the user's home directory (because of root squashing nfs,
ACLs, etc...).  GDM should first seteuid/setegid to the user before
testing for the existance of the user's home directory.  Note this bug
is the same bug as Bug 149580, but for tracking the RHEL-4 erratum
instead of RHEL-3.

Comment 4 Tim Powers 2005-06-09 12:11:44 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-151.html



Note You need to log in before you can comment on or make changes to this bug.