Bug 149928 - rhnpush fails on RH supplied packages
rhnpush fails on RH supplied packages
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Max Spevack
:
Depends On:
Blocks: 147875
  Show dependency treegraph
 
Reported: 2005-02-28 15:50 EST by Ian McLeod
Modified: 2007-10-23 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 16:18:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error returned on the command line after failed push. (2.37 KB, text/plain)
2005-02-28 15:57 EST, Ian McLeod
no flags Details
Logfile output during failed push (7.57 KB, text/plain)
2005-02-28 15:57 EST, Ian McLeod
no flags Details

  None (edit)
Description Ian McLeod 2005-02-28 15:50:23 EST
Description of problem:

rhnpush fails without helpful debug output when attempting to push
tmpwatch-2.8.4-5.i386.rpm.  We believe this may be related to
international characters being included in the author string and/or
the changelog.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. rhnpush tmpwatch-2.8.4-5.i386.rpm to a custom channel on a 3.4
Satellite
2.
3.
  
Actual results:

The push fails and returns a snipit of XML

Expected results:

The package should be added to the channel.


Additional info:

Look for the following file attachments with more detailed output:

pusherror_commandline - XML output seen on the command line after
failed push

pusherror_logfile - Log file output (at debug level 4) when attempting
the failed push
Comment 1 Ian McLeod 2005-02-28 15:57:20 EST
Created attachment 111497 [details]
Error returned on the command line after failed push.
Comment 2 Ian McLeod 2005-02-28 15:57:55 EST
Created attachment 111498 [details]
Logfile output during failed push
Comment 3 Mihai Ibanescu 2005-05-17 11:46:05 EDT
Is this still an issue?
Comment 4 John Wregglesworth 2005-06-03 16:18:58 EDT
I'm closing the bug because I tried to push the same package into a channel with
rhnpush-3.7.1.1-5.rhel4 on a 4.0-42 satellite and on webqa and encountered no
errors.

Note You need to log in before you can comment on or make changes to this bug.