Bug 149992 - Installer crashes when trying to reuse existing partitions
Installer crashes when trying to reuse existing partitions
Status: CLOSED DUPLICATE of bug 88359
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 06:43 EST by Michael Young
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 16:18:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash dump log (73.47 KB, text/plain)
2005-03-01 06:45 EST, Michael Young
no flags Details

  None (edit)
Description Michael Young 2005-03-01 06:43:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
I am trying to get kickstart to reuse some existing partitions via the lines
part raid.0 --onpart=sda1
part raid.1 --onpart=sdb1
raid / --fstype=ext3 --level=RAID1 raid.0 raid.1
part swap --onpart=sda2
part swap --onpart=sdb2
to preserve the data on the other partitions and anaconda crashes with the error
AttributeError: 'NoneType' object has no attribute 'getActualSize'


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Michael Young 2005-03-01 06:45:57 EST
Created attachment 111528 [details]
Crash dump log

The dump from the anaconda crash
Comment 2 Michael Young 2005-03-01 10:28:39 EST
The error seems to be with the raid disks (which incidentally are exactly the
same size). I have now worked around the problem by removing the sda1 and sdb1
partitions, then letting it size the raid itself (having made sure that the only
free space was where sda1 and sdb1 had been).
Comment 3 Chris Lumens 2005-03-01 16:18:46 EST

*** This bug has been marked as a duplicate of 88359 ***

Note You need to log in before you can comment on or make changes to this bug.