Bug 150002 - 1.0.1 update broke font rendering, text box handling
Summary: 1.0.1 update broke font rendering, text box handling
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-01 15:08 UTC by Chris Evans
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 1.0.3-1.3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 06:34:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Evans 2005-03-01 15:08:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
The update broke font rendering and text box handling.
I strongly suspect the changelog entry which basically says "use pango" is going to be responsible. Let's look at the two breakages:

Font rendering: italic fonts are rendered clipped at the right-hand side. It's very noticeable and ugly. Let me know if you want before and after screenshots.

Text box handling: Using the "home" and "end" keys doesn't always work properly. Pasting in text with the middle button sometimes pastes at the beginning of the line rather than where the cursor is.

Version-Release number of selected component (if applicable):
firefox-1.0.1-1.3.1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Comment 1 Christopher Blizzard 2005-03-24 01:03:48 UTC
The italic fonts issue should be fixed in the update we just did.  The text box
handling seems to be this bug that I just filed:

http://bugzilla.gnome.org/show_bug.cgi?id=171439

Comment 2 Christopher Blizzard 2005-04-25 17:56:23 UTC
OK, both of these issues should be fixed in 1.0.3-1.3.1.


Note You need to log in before you can comment on or make changes to this bug.