Bug 150004 - samba mishandles plaintext passwords
samba mishandles plaintext passwords
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
NdRvw
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 11:09 EST by Steve Conklin
Modified: 2014-08-31 19:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 16:36:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the patch from the samba BZ that reportedly solved the problem (814 bytes, patch)
2005-03-01 11:09 EST, Steve Conklin
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 2323 None None None Never

  None (edit)
Description Steve Conklin 2005-03-01 11:09:52 EST
Created attachment 111529 [details]
This is the patch from the samba BZ that reportedly solved the problem
Comment 1 Steve Conklin 2005-03-01 11:09:52 EST
Description of problem:

Samba mishandles plaintext passwords

Using samba 3.0.10 on RHEL 3 as server (using unencrypted passwords and PAM
auth) and a Win XP client machine.  On initial attempt to connect, we've been
seeing PAM auth failures that I've traced back to the server seeing password =
username despite that not being the case on the wire (password is NULL as
windows appears to be trying NULL before promtping for a password).

https://bugzilla.samba.org/show_bug.cgi?id=2323
Comment 14 David Lawrence 2006-04-18 16:37:06 EDT
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.

Note You need to log in before you can comment on or make changes to this bug.