Bug 150008 - Computer hangs when enabling wireless (ipw2200) on toshiba tecra M2
Computer hangs when enabling wireless (ipw2200) on toshiba tecra M2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 11:36 EST by Stuart Campbell
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEL4U2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 11:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Campbell 2005-03-01 11:36:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
If I enable the wireless interface from the slide switch on the laptop the computer freezes (except for the caps lock light flashes on/off).

This worked perfectly under RHEL 4 Beta2.

This happens with Toshiba Tecra M1 and M2 models.

The last entries in /var/log/messages are ...

Feb 25 14:08:29 diamrl9087 kernel: Debug: sleeping function called from invalid context at mm/slab.c:2061
Feb 25 14:08:29 diamrl9087 kernel: in_atomic():0, irqs_disabled():1
Feb 25 14:08:29 diamrl9087 kernel:  [<c01188af>] __might_sleep+0x7b/0x85
Feb 25 14:08:29 diamrl9087 kernel:  [<c0147e58>] kmem_cache_alloc+0x1b/0x45
Feb 25 14:08:29 diamrl9087 kernel:  [<c024268f>] request_firmware+0x2b/0x136
Feb 25 14:08:29 diamrl9087 kernel:  [<f8954263>] ipw_get_fw+0x16/0x53 [ipw2200]
Feb 25 14:08:29 diamrl9087 kernel:  [<f89542ce>] ipw_load+0x2e/0x48f [ipw2200]
Feb 25 14:08:29 diamrl9087 kernel:  [<f895863f>] ipw_up+0x3f/0xb6 [ipw2200]
Feb 25 14:08:29 diamrl9087 kernel:  [<f8956804>] ipw_adapter_restart+0x1b/0x2c [ipw2200]
Feb 25 14:08:29 diamrl9087 kernel:  [<f8957df4>] ipw_rf_kill+0xc7/0x12e [ipw2200]
Feb 25 14:08:29 diamrl9087 kernel:  [<c012dd4b>] worker_thread+0x1ff/0x31b

Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.3.EL

How reproducible:
Always

Steps to Reproduce:
1. Boot laptop (Toshiba Tecra M1 or M2)
2. enable wireless interface via hardware switch

  

Actual Results:  Computer locks

Expected Results:  Wireless interface enabled - as experienced in RHEL Beta2

Additional info:
Comment 2 Stuart Campbell 2005-03-24 11:04:37 EST
This problem seems to be solved in the latest rawhide kernel.
Comment 3 John W. Linville 2005-04-25 15:28:26 EDT
FWIW, the ipw2200 driver is the same in rawhide, fc3, and rhel4... 
 
The kernels here have an updated ipw2200 driver: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
This is the same driver that is schedule for U1.  Could you give it a try and 
report back the results?  Thanks! 
Comment 4 Stuart Campbell 2005-05-03 03:21:37 EDT
This seems to work perfectly.  
Thank you

Note You need to log in before you can comment on or make changes to this bug.