Bug 150016 - Files owned by a non-root account (build.build)
Summary: Files owned by a non-root account (build.build)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: synce   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 149782 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-01 17:36 UTC by Jose Pedro Oliveira
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-02 01:26:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jose Pedro Oliveira 2005-03-01 17:36:37 UTC
Description of problem:
The synce-devel RPM files are owned by the build account. They
should belong to the root account. The specfile is missing a
%defattr(-,root,root,-) statement.

Version-Release number of selected component (if applicable):
synce-devel-0.9.0-1.i386.rpm

How reproducible:
rpm -qplv synce-devel

Additional info:
This patch should be applied to the FC-3 and devel CVS directories
----------
--- synce.spec  8 Dec 2004 15:47:19 -0000       1.1
+++ synce.spec  1 Mar 2005 17:30:28 -0000
@@ -99,7 +99,7 @@
 rm -rf $RPM_BUILD_ROOT

 %files
-%defattr(-,root,root)
+%defattr(-,root,root,-)
 #%doc README LICENSE

 #libsynce
@@ -147,6 +147,7 @@
 %{_mandir}/man8/synce-serial-*

 %files devel
+%defattr(-,root,root,-)
 %{_includedir}/*.h
 %{_libdir}/lib*.a
 %{_libdir}/lib*.la
----------

Comment 1 Michael Schwendt 2005-03-01 20:50:05 UTC
*** Bug 149782 has been marked as a duplicate of this bug. ***

Comment 2 Warren Togami 2005-04-02 01:26:38 UTC
checking in...


Note You need to log in before you can comment on or make changes to this bug.