Bug 150041 - Pango Firefox loses spaces between text and anchor in italicized text
Pango Firefox loses spaces between text and anchor in italicized text
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
: 150289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 16:33 EST by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 19:46:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example rendering error (57.86 KB, image/png)
2005-03-01 16:33 EST, Nicholas Miell
no flags Details
patch to fix problems (2.79 KB, patch)
2005-03-21 21:43 EST, Christopher Blizzard
no flags Details | Diff

  None (edit)
Description Nicholas Miell 2005-03-01 16:33:26 EST
In the recently released Pango-enabled Firefox errata package for FC3, spaces
between italicized text and an italicized hyperlink are sometimes lost.

See attached image for an example. I verified that the original HTML does
contain spaces between the text and the anchor.
Comment 1 Nicholas Miell 2005-03-01 16:33:27 EST
Created attachment 111551 [details]
example rendering error
Comment 2 Christopher Blizzard 2005-03-01 16:45:25 EST
What fonts are you using for your sans and sans-serif fonts in your preferences?
Comment 3 Nicholas Miell 2005-03-01 17:04:42 EST
Bitstream Vera Serif and Bitstream Vera Sans.

Note that it doesn't always omit the space; the example I gave was cropped for size.
Comment 4 Jon Orris 2005-03-01 18:02:30 EST
I've replicated this using those fonts.
Setting MOZ_DISABLE_PANGO=1 eliminates the problem.
Comment 5 Christopher Aillon 2005-03-04 09:19:46 EST
*** Bug 150289 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Blizzard 2005-03-21 21:43:13 EST
Created attachment 112199 [details]
patch to fix problems

This patch fixes the rounding errors that were causing this bug.
Comment 7 Christopher Blizzard 2005-03-21 21:43:52 EST
This will be fixed in the next fc3 errata build.
Comment 8 Christopher Aillon 2005-03-31 04:47:25 EST
Yeah, fixed in fc3 and rawhide.
Comment 9 Nicholas Miell 2005-04-20 15:43:17 EDT
Was firefox-1.0.3-1.3.1 supposed to fix this? I'm still seeing it.
Comment 10 Warren Togami 2005-09-30 15:42:07 EDT
I haven't seen this for a while.  Are you still seeing this issue?

Note You need to log in before you can comment on or make changes to this bug.