Bug 150076 - Exception "TypeError: rpmdb open failed" during FC3 install
Exception "TypeError: rpmdb open failed" during FC3 install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 00:39 EST by Matthew Zimmerman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 07:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gzipped anacdump.txt (slightly truncated due to bad floppy disk) (3.78 KB, application/x-gzip)
2005-03-02 00:47 EST, Matthew Zimmerman
no flags Details

  None (edit)
Description Matthew Zimmerman 2005-03-02 00:39:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
In the process of upgrading an FC1 system to FC3, I'm getting a fatal exception about the system being unable to open rpmdb (more details below). My system has a relatively small hard drive, divided into several 3-5 GB partitions:


root@bester / $ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hdc2             4.9G  3.8G  802M  83% /
/dev/hdc1             291M   17M  260M   7% /boot
/dev/hdc3             3.9G  2.4G  1.3G  66% /home
/dev/hdc5             2.9G  406M  2.4G  15% /data
/dev/hdc6             2.9G  1.9G  911M  68% /usr/local
/dev/hda1             9.5G  8.9G  650M  94% /win/c
/dev/hdc8             3.8G  2.8G  1.1G  73% /win/d
none                   93M     0   93M   0% /dev/shm


My root partition, as you can see, is very small, so I moved my /var and /tmp directories to the /data (/dev/hdc5) partition:


root@bester /data $ ls -l
total 32
drwx------   2 root root 16384 Jul 21  2002 lost+found
drwxrwxrwt  46 root root  4096 Mar  2 00:05 tmp
drwxr-xr-x  19 root root  4096 Mar  1 23:15 var


and then added relative symlinks to them on the root partition (/dev/hdc2):


root@bester / $ ls -l
...
lrwxrwxrwx    1 root root     11 Mar  1 18:05 tmp -> ../data/tmp
...
lrwxrwxrwx    1 root root     11 Mar  1 18:05 var -> ../data/var
...


When I tried to upgrade to FC3, I get an exception when anaconda first starts calculating package dependencies that ends in "TypeError: rpmdb open failed" (anacdump.txt is attached below). This is the step immediately after "Reading package information", but before it give you the final opportunity to abort the installation. I have no trouble accessing the rpm database booted into FC1, and rpm --rebuilddb doesn't help.

Curiously, if I rearrange these directories by moving /tmp directly to the / partition, and mounting /dev/hdc5 as /var (moving subdirectories as appropriate), anaconda successfully completes this step, but the overall installation fails as I run out of space on the / partition (about 270 MB shy). My best guess is that anaconda is not mounting /data before attempting to access  /var/lib/rpm. 

Clearly I'm somewhat pressed for space, and I often have to play games with symlinks to prevent partitions from filling up. Any suggestions on how I could get FC3 to install?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above.
  

Additional info:

This is an older system: a Dell Dimension L500cx (Celeron 500 MHz), 192MB RAM, two  IDE hard disks (/dev/hda - Windows 98 SE - 10GB, /dev/hdc - Fedora Core 1 - 20GB).
Comment 1 Matthew Zimmerman 2005-03-02 00:47:06 EST
Created attachment 111563 [details]
Gzipped anacdump.txt (slightly truncated due to bad floppy disk)
Comment 2 Paul Nasrat 2005-03-02 05:12:11 EST
Anaconda expects the contents of fstab to match your hard disk layout - have you
tried bind mounts that should work - something like this in fstab rather than
symlinks (remove the symlinks and create the dirs):

/var /data/var none bind 0 0
/tmp /data/tmp none bind 0 0 

Comment 3 Matthew Zimmerman 2005-03-02 07:56:55 EST
Oh, I'm so embarrassed- my relative symlinks are wrong. I have them pointing
like this

/tmp -> ../data/tmp

instead of

/tmp -> data/tmp

When the root device is mounted as /, this works as the '..' part is ignored,
but if you're NOT mounting it there, well... I've changed it and will try the
install again, but in any case we're probably safe in closing this one. Is there
a SUBMITTERISANIDIOT flag?

Note You need to log in before you can comment on or make changes to this bug.