Bug 150081 - SpamAssassin uses wrong IP addresses in RBL check.
SpamAssassin uses wrong IP addresses in RBL check.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 04:40 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 20:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-03-02 04:40:08 EST
SA has some heuristics in Received.pm to determine which Received:
headers should be ignored. Those with IP addresses in RFC1918 domains
are ignored, for example. 

We should also refrain from doing RBL checks on the IP address shown
in  Received: headers which show that the message was transmitted by
_authenticated_ SMTP. According to RFC3848, this is shown by the use
of 'by esmtpa' or 'by esmtpsa' in the Received: header.
Comment 1 Justin Mason 2005-03-02 05:03:12 EST
I believe these issues may be fixed in the (as yet unreleased) SA
3.1.x tree.

http://bugzilla.spamassassin.org/show_bug.cgi?id=2462 is the auth-SMTP
fix.
Comment 2 David Woodhouse 2005-03-02 05:14:49 EST
Looks like a patch exists for 3.0.x too. 

Btw, we should also be dropping IPv6 addresses in reserved ranges,
especially those with non-global scope.
Comment 3 Warren Togami 2005-03-31 06:20:04 EST
> Looks like a patch exists for 3.0.x too.

If you want this in FC4, please supply a unidiff patch for me.  Make sure your
patch wont cause problems for us because I wont test it before applying it.
Comment 4 David Woodhouse 2005-03-31 06:34:53 EST
Nah, FC4 is useless for mail for me anyway; I'll not bother updating my FC3
machines until FC5 comes out.
Comment 5 Warren Togami 2005-04-03 06:42:04 EDT
David I am now actively going through upstream 3.0.3 target bugs and looking for
the most critical 3.1.0 stuff to backport.  Working with the Debian spamassassin
maintainer because we have the common goal of making a real 3.0.3 maintenance
release.  If you consider this issue to be serious enough to warrant a 3.0.3
backport, please open a new bug in upstream bugzilla, CC me and report in this
bug the URL.  In the upstream report include your backported 3.0.x patch for
target inclusion in 3.0.3.

http://people.redhat.com/wtogami/temp/spamassassin/
FC2 and FC3 packages of spamassassin-3.0.2 plus stuff already checked into 3.0
branch of SVN.  If you want to rebuild for ppc check out the package from FC4.
Comment 6 Warren Togami 2005-04-25 20:56:12 EDT
Looks like it was applied to r112026 in b3_0, so it will be in 3.0.3.  Already
in rawhide.

Note You need to log in before you can comment on or make changes to this bug.