Bug 150100 - [patch] man, and other commands requiring temp files, don't work in Repair Filesystem mode
[patch] man, and other commands requiring temp files, don't work in Repair Fi...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 10:20 EST by Robin Green
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 16:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one-line patch (392 bytes, patch)
2005-03-02 10:20 EST, Robin Green
no flags Details | Diff
Better patch (989 bytes, patch)
2005-03-02 11:01 EST, Robin Green
no flags Details | Diff

  None (edit)
Description Robin Green 2005-03-02 10:20:35 EST
Description of problem:
Commands like man don't work in Repair Filesystem mode, because /tmp is normally
on a read-only filesystem, namely /
Attached one-liner fixes this issue.

Version-Release number of selected component (if applicable):
initscripts-7.93.5-1

How reproducible:
Every time

Steps to Reproduce:
1. Corrupt your filesystem ;-)
2. Reboot
3. fsck fails and rc.sysinit brings you to Repair Filesystem mode
4. type "man script"
  
Actual results:
Nothing is displayed

Expected results:
man page for "script" should be displayed
Comment 1 Robin Green 2005-03-02 10:20:36 EST
Created attachment 111578 [details]
one-line patch
Comment 2 Robin Green 2005-03-02 11:01:12 EST
Created attachment 111579 [details]
Better patch

This covers all three code paths that can enter some sort of "repair mode".
Comment 3 Bill Nottingham 2005-10-03 16:54:22 EDT
Apologies for the lack of response.

I'm not sure this is a great idea, as it changes the view of the filesystem
you're repairing from normal, and doesn't give any indication that that space is
not going to be preserved to the next boot. Hence, WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.