Bug 150146 - x86_64 up and smp kernel oops on boot (with 2.6.11-1.1166)
Summary: x86_64 up and smp kernel oops on boot (with 2.6.11-1.1166)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-02 21:34 UTC by Jeremy Katz
Modified: 2015-01-04 22:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 22:02:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2005-03-02 21:34:05 UTC
Oops on boot on EM64t box.

The UP oops looks like
RIP: huft_build

Call trace:
__rmqueue
buffered_rmqueue
__aloc_pages
attach_pid
inflated_fixed
cache_alloc_debugcheck_after
unpack_to_rootfs
populate_rootfs
init
init
child_rip
init
child_rip

Comment 1 Michal Jaegermann 2005-03-03 00:07:12 UTC
I did not get that far on UP AMD64.  The last lines on a screen say:

Detected 12.500 MHz APIC timer.
Kernel panic - not syncing: invalid compressed format (err=1)

although this is 2.6.11-1.1162_FC4 currently in rawhide.

Comment 2 Dan Witte 2005-03-04 08:40:24 UTC
kernel-2.6.11-1.1166_FC4 on UP x86_64, similar result to comment 1, when booting
the kernel from the installer image:

Using local APIC NMI watchdog using perfctr0.
Using local APIC timer interrupts.
Detected 12.436MHz APIC timer.
Kernel panic - not syncing: invalid compressed format (err=1)

Also occurs with kernel-2.6.10-1.1162_FC4. Adding any of the boot parameters
"noapic", "nolapic", or "acpi=off" results in a trace dump from the kernel, with
the last line:

Kernel panic - not syncing: attempted to kill init!

(The oops mentions huft_build, perhaps similar to that in comment 0.)

Comment 3 Dan Witte 2005-03-04 08:50:10 UTC
2/17/05 kernel build works. (It hangs when running /sbin/loader unless booted
with "noapic nolapic acpi=off", but that's probably unrelated.)


Note You need to log in before you can comment on or make changes to this bug.