Bug 150153 - options for httpd is not working
options for httpd is not working
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 18:30 EST by Lene Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-03 04:32:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lene Jensen 2005-03-02 18:30:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
When trying some of the options (I haven't tried all), there is no output:
httpd -l returns nothing. Same with httpd -t, httpd -S, httpd -h, httpd -t -D DUMP_VHOSTS, httpd -v, httpd -X, httpd -w and httpd -V.


Version-Release number of selected component (if applicable):
httpd-2.0.52-9.ent

How reproducible:
Always

Steps to Reproduce:
1. Install httpd-2*
2. httpd -t
3. edit /etc/httpd/conf/httpd.conf and insert an obvious error
4. run httpd -t again

  

Actual Results:  The command returns without any output.


Expected Results:  I would expect it say "Syntax OK" on number 2, and an error specific to the error created as output for number 4

Additional info:

The manpages explicitely explains the options, hence, they should be there. If they are not supposed to be there anymore, which would be a shame, then I would expect the manpages to change.
Comment 1 Joe Orton 2005-03-03 04:32:05 EST
This is due to the SELinux targeted policy, which prevents httpd from having
access to the terminal by default; the output is just being lost.

To work around it, you can use:

# httpd -t | cat

but tools like apachectl and the init script already know to DTRT, so that:

# service httpd configtest
# apachectl configtest

will work as intended.


Note You need to log in before you can comment on or make changes to this bug.