Bug 150170 - de-selecting packages after failed attempt to install repeats errors
de-selecting packages after failed attempt to install repeats errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 04:02 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 11:23:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-03-03 04:02:17 EST
If you run up2date --show-package-dialog, select a few repos, select
several packages to install, one of which has broken dependencies,
then proceed to install, you get an error indicating what the problem
is.  If you go back, de-select that package, and attempt to install
the remaining ones, you get the same error.  If you leave up2date,
start it again with this option, select the same repos, the same
packages except for the broken one, it works.  It appears that the set
of packages to install is retained over going back.

The same problem is present in the repository selection.  If you
select several repositories, go forward up to the package selection
window, then realize you selected too many repos, then you try to go
back, de-select some of them, and go forward again, you'll still get
packages from the de-selected repository listed.

Version-Release number of selected component (if applicable):
up2date-4.4.9-1

How reproducible:
Always
Comment 1 John Thacker 2006-10-29 15:23:33 EST
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.
Comment 2 John Thacker 2006-11-05 11:23:31 EST
Closing per previous message.

Note You need to log in before you can comment on or make changes to this bug.