Bug 150174 - DRI disabled on Mobility Radeon 7500
DRI disabled on Mobility Radeon 7500
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-03-03 05:05 EST by Yue Shi Lai
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 10:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg server log (35.47 KB, text/plain)
2005-03-03 05:05 EST, Yue Shi Lai
no flags Details

  None (edit)
Description Yue Shi Lai 2005-03-03 05:05:44 EST
Description of problem:

After installing RHEL 4 WS on IBM ThinkPad R40 with Mobility Radeon 7500, DRI is
disabled. However, using nightly build (20050225) of dri.sourceforge.net, DRI
works fine, even without installing a new X.org server.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.1-23.EL

How reproducible:

Always

Steps to Reproduce:
1. Install on a Mobility Radeon 7500 machine
2. Run glxinfo or look at /var/log/Xorg.0.log
3.
  
Actual results:

DRI is disabled, software Mesa is used

Expected results:

DRI is enabled, DRI accelerated Mesa is used

Additional info:
Comment 1 Yue Shi Lai 2005-03-03 05:05:44 EST
Created attachment 111609 [details]
Xorg server log
Comment 2 Mike A. Harris 2005-03-11 14:02:45 EST
The "radeon" driver included in RHEL 4, has DRI compiled in but
disabled by default due to some instability that was found on
certain combinations of hardware.  In order to use DRI you must
manually re-enable it by editing the config file and using
the following in the device section:

    Option "DRI"

If you have further problems, please contact Red Hat Global Support
Services via telephone at 1-888-RED-HAT1 and a support representative
will assist.

Thanks.
Comment 3 Mike A. Harris 2005-03-11 14:03:45 EST
Setting status to "NOTABUG".
Comment 4 Mike A. Harris 2005-04-16 02:48:06 EDT
Informational update:

We have been diagnosing the various DRI lockup problems that various people
have reported for the "radeon" driver, and have made some progress, however
the current driver still has instabilities so we've decided to leave DRI
disabled by default on "radeon" for the upcoming RHEL4 U1 update.

In the mean time, users can still use the 'Option "dri"' override suggested
in comment #2 above to manually override the default and force DRI to be
enabled.  Users are cautioned however that enabling DRI override, may cause
system instability.

We will continue to work with X.Org on resolving the DRI lockups in the
"radeon" driver, and look forward to being able to provide RHEL 4 customers
with stable DRI in a future update.

Comment 15 Mike A. Harris 2005-07-12 14:03:08 EDT
Patch added to 6.8.2-1.EL3.13.11 to allow DRI on Radeon by default
except for Radeon 7000, which is disabled by default due to other
problems which are still being investigated.

Please test this build or a later build during RHEL alpha/beta
testing releases and indicate if the problem is now resolved
or not.

Thanks in advance.

Setting status to "MODIFIED", pending testing.
Comment 16 Mike A. Harris 2005-07-14 20:38:11 EDT
ftp://people.redhat.com/mharris/testing/4E/xorg-x11/6.8.2-1.EL.13.11

Please test this build as soon as possible and report back the results,
to ensure there is enough time for us to review the problem again and
try other solutions if the issue remains.

Thanks in advance.
Comment 18 Fedora Update System 2005-09-16 17:26:13 EDT
From User-Agent: XML-RPC

xorg-x11-6.8.2-1.FC3.45 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 19 Red Hat Bugzilla 2005-10-05 10:32:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-500.html
Comment 20 Jim Castleberry 2005-10-28 15:31:41 EDT
Installing the RHEL U2 updates, including xorg-x11-6.8.2-1.EL.13.20, on my Dell
Poweredge SC1425 (Chipset: "ATI Radeon VE/7000 QY (AGP/PCI)" (ChipID = 0x5159))
broke X.  When it should display the gdm login screen the display goes dark and
my LCD monitor complains about invalid sync frequencies.  The X process is hung
and can not be killed.

Adding 'Option "DRI" "off"' to the Device section of xorg.conf doesn't help.
/var/log/Xorg.0.log shows that it sees the Option line but still loads and
enables DRI.  Removing the 'Load "dri"' line from the Module section instead of
adding the Option line does the trick - DRI isn't loaded and X works as it did
before the update.

BTW, there's a misleading message in Xorg.0.log:
   (WW) RADEON(0): Direct Rendering is disabled by default on Radeon VE/7000
           hardware due to instability, but has been forced on with
           "Option "dri" in xorg.conf.  You may experience instability.
As I understand it DRI is now enabled by default, plus that message is generated
whether or not DRI is loaded or enabled and whether or not there's an "Option
DRI" or "Load DRI" line in xorg.conf.
Comment 21 Mike A. Harris 2005-10-28 15:41:16 EDT
(In reply to comment #20)
> Installing the RHEL U2 updates, including xorg-x11-6.8.2-1.EL.13.20, on my Dell
> Poweredge SC1425 (Chipset: "ATI Radeon VE/7000 QY (AGP/PCI)" (ChipID = 0x5159))
> broke X.  When it should display the gdm login screen the display goes dark and
> my LCD monitor complains about invalid sync frequencies.  The X process is hung
> and can not be killed.
> 
> Adding 'Option "DRI" "off"' to the Device section of xorg.conf doesn't help.
> /var/log/Xorg.0.log shows that it sees the Option line but still loads and
> enables DRI.  Removing the 'Load "dri"' line from the Module section instead of
> adding the Option line does the trick - DRI isn't loaded and X works as it did
> before the update.
> 
> BTW, there's a misleading message in Xorg.0.log:
>    (WW) RADEON(0): Direct Rendering is disabled by default on Radeon VE/7000
>            hardware due to instability, but has been forced on with
>            "Option "dri" in xorg.conf.  You may experience instability.
> As I understand it DRI is now enabled by default, plus that message is generated
> whether or not DRI is loaded or enabled and whether or not there's an "Option
> DRI" or "Load DRI" line in xorg.conf.
> 

See bug #170008

Note You need to log in before you can comment on or make changes to this bug.