Bug 150175 - USB2 Card reader does not work if plugged with a card
USB2 Card reader does not work if plugged with a card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 05:11 EST by drago01
Modified: 2015-01-04 17:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-01 17:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (325.82 KB, application/octet-stream)
2005-03-03 05:14 EST, drago01
no flags Details
Erros that happens with 2.6.11-1.7_FC3 (41.43 KB, text/plain)
2005-03-27 02:41 EST, drago01
no flags Details

  None (edit)
Description drago01 2005-03-03 05:11:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
I bought a new USB2 card reader.
When I plug it in and a card is in it it causes 60-80% cpu load and don't work.
If I plug it in without a card and wait for 3-5secs before inserting a card it works fine. 

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1. Plug the card reader with an inserted card
2. look at the cpu load (top)
3. notice that it is very high an that nothing gets mounted by udev,hal etc.
  

Actual Results:  It don't work when I plug it in with an inserted card.

Expected Results:  It should work if I plug it in with an inserted card.

Additional info:

---------
lsusb
Bus 003 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 0424:20fc Standard Microsystems Corp.
Bus 001 Device 001: ID 0000:0000
---------
this messages are in dmesg when I it works:
------------------------------------------usb 1-5: new high speed USB device using ehci_hcd and address 6
usb 1-5: device descriptor read/64, error -71
scsi3 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
  Vendor: Generic   Model: USB 2 HS-CF       Rev: 1.95
  Type:   Direct-Access                      ANSI SCSI revision: 00
Attached scsi removable disk sda at scsi3, channel 0, id 0, lun 0
  Vendor: Generic   Model: USB 2 HS-MS       Rev: 1.95
  Type:   Direct-Access                      ANSI SCSI revision: 00
Attached scsi removable disk sdb at scsi3, channel 0, id 0, lun 1
  Vendor: Generic   Model: USB 2 HS-SM       Rev: 1.95
  Type:   Direct-Access                      ANSI SCSI revision: 00
Attached scsi removable disk sdc at scsi3, channel 0, id 0, lun 2
  Vendor: Generic   Model: USB 2 HS-SD/MMC   Rev: 1.95
  Type:   Direct-Access                      ANSI SCSI revision: 00
Attached scsi removable disk sdd at scsi3, channel 0, id 0, lun 3
usb-storage: device scan complete
SCSI device sdd: 29120 512-byte hdwr sectors (15 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 29120 512-byte hdwr sectors (15 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
 sdd: sdd1
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
SELinux: initialized (dev sdd1, type vfat), uses genfs_contexts
---------------------------------------------- 
I will attach a gzipped /var/log/messages after submiting this report, which contains the errors that come when It fails.
Comment 1 drago01 2005-03-03 05:14:06 EST
Created attachment 111610 [details]
/var/log/messages

Here is the /var/log/messages file with the errors in it.
Comment 2 drago01 2005-03-04 08:10:53 EST
Seems to be fixed with 2.6.10-1.770_FC3
Comment 3 drago01 2005-03-21 11:53:29 EST
this isn't fixed it happend 3 times today with 2.6.10-1.770_FC3
Comment 4 drago01 2005-03-21 11:58:10 EST
lspci shows this:
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 0080 (rev a3)
00:01.1 SMBus: nVidia Corporation MCP2A SMBus (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP2A USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP2A USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation MCP2A USB Controller (rev a2)
00:04.0 Bridge: nVidia Corporation MCP2A Ethernet Controller (rev a3)
00:08.0 PCI bridge: nVidia Corporation MCP2A PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation MCP2A IDE (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600/GeForce
6600 GT] (rev a2)
02:07.0 Multimedia controller: Philips Semiconductors SAA7134 (rev 01)
02:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
02:09.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
02:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 46)
Comment 5 Paul F. Johnson 2005-03-22 07:16:15 EST
I'm not seeing this with any of the rawhide kernels
Comment 6 drago01 2005-03-22 07:20:38 EST
can you reporduce this errors with a FC3 kernel?
Comment 7 drago01 2005-03-27 02:23:45 EST
still broken with kernel-2.6.11-1.7_FC3:
SCSI device sdd: 29120 512-byte hdwr sectors (15 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 29120 512-byte hdwr sectors (15 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
 sdd: sdd1
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28985
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28986
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28987
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28988
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28989
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28990
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28991
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28992
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28985
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28986
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28987
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28988
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28989
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28990
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28991
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 28992
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 57
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 58
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 59
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 60
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 61
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 62
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 63
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 64
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 57
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 58
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 59
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 60
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 61
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 62
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 63
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 64
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 569
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 570
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 571
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 572
SCSI error : <0 0 0 3> return code = 0x70000
end_request: I/O error, dev sdd, sector 573
Comment 8 drago01 2005-03-27 02:41:51 EST
Created attachment 112372 [details]
Erros that happens with 2.6.11-1.7_FC3

It seems that the kernel detects the device sdd1 multiple times...
hald logs a timeout error.
Comment 9 drago01 2005-04-01 13:15:04 EST
added hal maintainer CC because this could be a hal bug..
I am using hal-0.4.7-1.FC3.
Comment 10 drago01 2005-05-01 05:32:31 EDT
After some testing in windows the card reader seems to be broken, but on windows
it does not eats 80-100% cpu load only the explorer crashes when it trys to list
the devices.
Is there a way to let broken devices not eat all the cpu load?
Comment 11 Dave Jones 2005-05-01 17:39:40 EDT
if its broken, theres not much we can do about it.  It's somewhat difficult to
distinguish a device thats overwhelming the system with interrupts/dma from a
device that does that as part of its regular functioning.
Whilst a card-reader shouldn't do this, its likely the cpu load is happening at
a layer higher up in the usb core.

Note You need to log in before you can comment on or make changes to this bug.