Bug 150198 - dchp and dhclient update doesn't work
dchp and dhclient update doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 11:49 EST by Tuomas A.
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-01 17:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomas A. 2005-03-03 11:49:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
For some reason, after updating dhcp and dhclient to version
3.0.1-40_FC3 the dhcp system will stop working correctly and the
connection to the internet will disappear.

This is some parts from /var/log/messages:
with 3.0.1-40_FC3:
-cut-
dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
dhclient: DHCPACK from 213.xxx.xxx.xxx
ifup: cp:
ifup: `/etc/resolv.conf' and `/etc/resolv.conf.predhclient' are the
same file
NET: /sbin/dhclient-script : updated /etc/resolv.conf
dhclient: bound to 213.xxx.xxx.xxx -- renewal in 7876 seconds.
ifup:  done.
-cut-

Still I can't get any connection to the internet with this version of
dhclient. Also dhcp 3.0.1-40_FC3 doesn't seem to give any working ip
address for other computers connected to my Linux-PC.

Version-Release number of selected component (if applicable):
dhcp-3.0.1-40_FC3, dhclient-3.0.1-40_FC3

How reproducible:
Always

Steps to Reproduce:
1. Update dhcp and dhclient from 3.0.1-30_FC3 to 3.0.1-40_FC3
2. Restart network

    

Additional info:
Comment 1 Jason Vas Dias 2005-03-03 11:56:34 EST
You probably have a 'GATEWAY=' setting in 
/etc/sysconfig/network-scripts/ifcfg-ethX 
for the ethX you are configuring with dhclient .

dhclient-3.0.1-40_FC3 now correctly honors the GATEWAY and 
GATEWAYDEV settings, and will, if GATEWAY is set, ONLY set
the default route to be via GATEWAY if GATEWAY is on the
subnet received from DHCP - otherwise, it sets NO default
route.

So your dhclient session is probably not setting the default
route.

Remove GATEWAY from /etc/sysconfig/network-scripts/ifcfg-ethX
and everything should work OK - let me know if not.


Comment 2 Tuomas A. 2005-03-07 14:59:11 EST
This was not the cause of this problem. Here are my ifcfg-ethX files
(eth0 is for internet connection, eth1 is for my laptop for sharing
the internet connection)

ifcfg-eth0:
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:10:B5:B4:6B:2F
ONBOOT=yes
TYPE=Ethernet
DHCP_HOSTNAME=hostname
USERCTL=no
PEERDNS=yes
IPV6INIT=yes

ifcfg-eth1:
DEVICE=eth1
BOOTPROTO=static
HWADDR=00:0C:6E:29:1F:BA
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=no
IPV6INIT=yes
IPADDR=192.168.0.1
NETMASK=255.255.255.0
GATEWAY=192.168.1.1


Am I really the only one who has this kind of problems or are the
others just unable to connect to the internet? :)
Comment 3 Jason Vas Dias 2005-03-07 15:08:18 EST
No, no problems with dhcp-3.0.1-40_FC3 have been reported except for
the 'GATEWAY=' issue. Do you have GATEWAYDEV set in 
/etc/sysconfig/network ?

Is the problem that you are using dhcpd serve addresses to a 
local client, and the local client does not get the IP address ? 

If so, please append the /etc/dhcpd.conf file from the server to this
bug. 

Please also do the following on the client:
 
 # ifdown eth0
 # ifconfig eth0 0.0.0.0 up
 # tcpdump -vvv -i eth0 -s 2048 port bootpc or port bootps \ 
   2>&1 | tee /tmp/dhcp_tcpdump.log &
 # tpid=$!
 # ifup eth0
 # kill $tpid

And then append the /tmp/dhcp_tcpdump.log to this bug - thanks.
   


Comment 4 Jason Vas Dias 2005-03-07 15:09:29 EST
The tcpdump command should have been:

# tcpdump -nl -vvv -i eth0 -s 2048 port bootpc or port bootps \ 
   2>&1 | tee /tmp/dhcp_tcpdump.log &

Comment 5 Tuomas A. 2005-03-07 15:59:11 EST
Ok, now I found the reason. I had GATEWAY and GATEWAYDEV defined in
/etc/sysconfig/network, didn't notice that one earlier. I removed the
settings and now the updated dhclient and dhcp packages work fine!

Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.