Bug 150211 - ftdi_sio.ko module has unknown symbol or unknown parameter
Summary: ftdi_sio.ko module has unknown symbol or unknown parameter
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-03 19:48 UTC by Tom Wood
Modified: 2015-01-04 22:17 UTC (History)
2 users (show)

Fixed In Version: kernel-2.6.12-1.1390_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 18:15:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract from dmesg of the problem for a USB to 4-port serial converter (1.87 KB, text/plain)
2005-03-03 19:50 UTC, Tom Wood
no flags Details

Description Tom Wood 2005-03-03 19:48:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
ftdi_sio module has several unknown symbols.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot with attached device using ftdi_sio module
2. Look for errors.
3.
  

Actual Results:  Errors stating problems with unknown symbols.

Expected Results:  No errors.


Additional info:

Comment 1 Tom Wood 2005-03-03 19:50:50 UTC
Created attachment 111632 [details]
Extract from dmesg of the problem for a USB to 4-port serial converter

Comment 2 Dave Jones 2005-03-04 22:16:28 UTC
how are you loading the ftdi_sio module ? Is it being done automatically on
insert ion of the device ?  I don't have one of the devices, but the module
loads just fine for me.


Comment 3 Tom Wood 2005-03-05 02:32:37 UTC
Automatically at boot time.  Device is already attached.

I find it interesting that the module also seems to assign the ttyUSB* devices,
even though it complains about quite a few symbols.

Comment 4 Dave Jones 2005-07-15 20:38:02 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 5 Tom Wood 2005-08-08 18:15:31 UTC
Fixed in current FC4.


Note You need to log in before you can comment on or make changes to this bug.