Bug 150215 - missing return statement
missing return statement
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 14:54 EST by David Binderman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 13:52:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-03-03 14:54:31 EST
Description of problem:

I just tried to compile supertux-0.1.2-1 from 
Redhat Fedora Extras development tree with the Intel C compiler.

The Intel compiler said

bitmask.cpp(81): warning #1011: missing return statement at end of
non-void function "bitmask_create_SDL"

I've checked the code and suggest add return statement at end of function.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steven Pritchard 2006-03-20 13:52:21 EST
Please report this issue upstream if the problem is still present in the current
release.
Comment 2 David Binderman 2006-03-20 15:15:23 EST
(In reply to comment #1)
> Please report this issue upstream if the problem is still present in the current
> release.

Good comedy.

Nothing happens to my bug report for a year, then you expect me to
do something about it ?

Perhaps a reminder that the Fedora project is a volunteer project
might be in order.
Comment 3 Steven Pritchard 2006-03-20 17:04:32 EST
a) I haven't owned this ticket for very long.
b) This bug report is old, for an old release of FC and supertux.
c) I have no interest in the Intel compiler.  The software's developers might.

I'm sorry if you don't like my response, but I don't want to leave a ticket open
for something that will not be fixed by me.

Note You need to log in before you can comment on or make changes to this bug.