Bug 150239 - compat-db contains a broken symlink which is immediately removed by ldconfig in %post
Summary: compat-db contains a broken symlink which is immediately removed by ldconfig ...
Status: CLOSED DUPLICATE of bug 150241
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: compat-db (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-03 21:44 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lehman 2005-03-03 21:44:26 UTC
Description of problem:
compat-db contains the following symlink:
lrwxrwxrwx    1 root    root               11 Sep 30 15:29 /usr/lib/libdb.so.3
-> libdb2.so.3

However, libdb2.so.3 is in /lib, not /usr/lib. So ldconfig removes it
immediately and creates the correct link named libdb.so.3 in /lib.

Version-Release number of selected component (if applicable):
compat-db-4.0.14-5.1

How reproducible:
Always

Steps to Reproduce:
1. install compat-db
2. rpm -V compat-db
3.
  
Actual results:
-bash-2.05b$ rpm -V compat-db
missing    /usr/lib/libdb.so.3


Expected results:
Successful verify of just-installed package

Additional info:

Comment 1 Jeff Johnson 2005-03-03 22:38:42 UTC

*** This bug has been marked as a duplicate of 150241 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:08:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.