Bug 150240 - compat-db contains a broken symlink which is immediately removed by ldconfig in %post
compat-db contains a broken symlink which is immediately removed by ldconfig ...
Status: CLOSED DUPLICATE of bug 150241
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: compat-db (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 16:44 EST by David Lehman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2005-03-03 16:44:54 EST
Description of problem:
compat-db contains the following symlink:
lrwxrwxrwx    1 root    root               11 Sep 30 15:29 /usr/lib/libdb.so.3
-> libdb2.so.3

However, libdb2.so.3 is in /lib, not /usr/lib. So ldconfig removes it
immediately and creates the correct link named libdb.so.3 in /lib.

Version-Release number of selected component (if applicable):
compat-db-4.0.14-5.1

How reproducible:
Always

Steps to Reproduce:
1. install compat-db
2. rpm -V compat-db
3.
  
Actual results:
-bash-2.05b$ rpm -V compat-db
missing    /usr/lib/libdb.so.3


Expected results:
Successful verify of just-installed package

Additional info:
Comment 1 Jeff Johnson 2005-03-03 17:39:35 EST

*** This bug has been marked as a duplicate of 150241 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.