Bug 150242 - LTC14305- strange results from log2up
LTC14305- strange results from log2up
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: mark wisner
:
Depends On:
Blocks: 156322 165152
  Show dependency treegraph
 
Reported: 2005-03-03 16:49 EST by Thomas Fitzsimmons
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2005-302
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 09:45:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demonstrates bug in log2up (512 bytes, text/x-java)
2005-03-03 16:49 EST, Thomas Fitzsimmons
no flags Details
this test case attempts to peg the blame squarely on the JIT compiler (596 bytes, text/plain)
2005-03-08 10:10 EST, Vadim Nasardinov
no flags Details
testcase showing that SR2 fixes this buh (627 bytes, text/plain)
2005-07-29 13:22 EDT, Vadim Nasardinov
no flags Details

  None (edit)
Description Thomas Fitzsimmons 2005-03-03 16:49:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
We're getting strange results from log2up when it is called multiple times from a loop.


Version-Release number of selected component (if applicable):
java-1.4.2-ibm-1.4.2.1-1jpp_2rh

How reproducible:
Always

Steps to Reproduce:
1. compile TestLog.java
2. run "java TestLog"


Actual Results:  $ java TestLog
Nonsensical result at ii=667


Expected Results:  $ java TestLog
ok

(exit status 0)


Additional info:
Comment 1 Thomas Fitzsimmons 2005-03-03 16:49:55 EST
Created attachment 111640 [details]
demonstrates bug in log2up
Comment 2 IBM Bug Proxy 2005-03-04 15:36:35 EST
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-03-04 15:30 EST -------
Reported bug to Java group. Eureka system PMR # is 80679,001,866 
Comment 3 IBM Bug Proxy 2005-03-07 10:28:57 EST
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-03-07 10:23 EST -------
Had a message from Java support indicating they were able to recreate this bug
and are debugging it. 
Comment 4 Vadim Nasardinov 2005-03-08 10:10:03 EST
Created attachment 111781 [details]
this test case attempts to peg the blame squarely on the JIT compiler

I'm posting this comment for the sole purpose of adding a couple more
search key words onto this ticket.  This should make it a little
easier to find when someone asks, half a year from now, "What was that
bug that looked like an error in IBM's JIT compiler?"

The following test does indeed make it look like an error in JITC.

| $ java -cp . JIT_Error
| J2RE 1.4.2 IBM build cxia32142ifx-20041203 (142SR1+80507) (JIT enabled: jitc)

| 
| Stack trace at ii=1999
| java.lang.Exception: Stack trace
|	  at java.lang.Thread.dumpStack(Thread.java:1101)
|	  at JIT_Error.main(JIT_Error.java:9)
| Broke after 2000 invocations
| java.lang.Exception: Stack trace
|	  at java.lang.Thread.dumpStack(Thread.java(Inlined Compiled Code))
|	  at JIT_Error.main(JIT_Error.java(Compiled Code))

A couple of things are going on here.  First of all, the test shows
that the arithmetic right-shift operator breaks after 2000
invocations.

Second of all, now that we now how many invocations it takes to break
the ">>" operator, we try to show that the error occurs only when JITC
kicks in.  To this end, we dump a stack trace at ii=1999.  Note that
the stack trace shows source line numbers.  In contrast, line numbers
are no longer present at ii=2000.  It just says "Compiled Code".
Comment 5 IBM Bug Proxy 2005-03-21 10:00:32 EST
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-03-21 09:55 EST -------
A few updates from Java team:

Recreated the problem using the testcase, it seems to be an issue specif
ic to linux as the same testcase passes on Windows on the same level of
the JRE : cxia32142-20040926.
Skipping JIT_Error.main circumvents the problem.
i.e export JITC_COMPILEOPT=SKIP{JIT_Error}{main}
or
export JITC_COMPILEOPT=NALL{JIT_Error}{main}

[-] 21/03/05 12:58 -- ABDUL, ASLAM -- AT: Add text

I have uploaded the recent build, sdk-20050315.tar.gz to
javaserv.hursley.ibm.com:/pmrs/aslam/80679( anonymous login ), This sdk
contains the fix ( libjitc.so ) for the reported problem, Could you
proceed with testing the fix and let me know the result.

I do notice a change in the size of libjitc.so file, I did test the lib
and is working fine , i suspect different levels of dependent libraries
on my local build machine is the cause of the size variation.

--------------------------------------------------------------------------------------

I am downloading the specified build to my machine since I believe that might be
an internal only server. Where does redhat want me to upload the build to for
their verification? 
Comment 6 IBM Bug Proxy 2005-03-21 13:05:38 EST
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-03-21 13:00 EST -------
The sdk-20050315.tar.gz file is 42107937 bytes in size. 
Comment 7 IBM Bug Proxy 2005-03-30 10:07:50 EST
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-03-30 10:04 EST -------
redhat,

The Java team uploaded the build sdk-20050315.tar.gz file mentioned for
verification to testcase.boulder.ibm.com:/ps/fromibm/internet/pmr80679. This ftp
site can be accessed by external users. Login as anonymous user to be able to
download the file.

The file will not be there for too long. Usually, the directories are cleaned up
after being there for 3 days so please take the time to download the file before
it gets removed. 
Comment 8 Thomas Fitzsimmons 2005-03-30 13:41:21 EST
I downloaded the tarball.
Comment 9 IBM Bug Proxy 2005-04-04 10:30:13 EDT
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-04-04 10:24 EST -------
Short update from Java team:

"tested with local recreate , the fix solves the reported problem" 
Comment 10 Thomas Fitzsimmons 2005-04-06 11:06:42 EDT
Yes, we've tested this and it works for us too.
Comment 12 IBM Bug Proxy 2005-05-16 10:51:57 EDT
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-05-16 10:47 EDT -------
Update from the PMR today:

ASLAM PERVEEZ ABDUL made update at 2005-05-16 05:53:00.0
Changes have been integrated to SR2. 
Comment 16 Thomas Fitzsimmons 2005-07-29 12:31:16 EDT
Is this fix in the IBM Java release SDK 1.4.2 SR2?

61928e68ec311b21413bcd06192e09ff *IBMJava2-JAVACOMM-142.ppc64.tgz
f2c6b0d4a1982d324d173a1a4d01b423 *IBMJava2-JAVACOMM-142.tgz
6b314b4bc20303b7cbf8a35ce603adaf *IBMJava2-JAVACOMM-AMD64-142.x86_64.tgz
019b1f399a0c8009460633ea27ca68d6 *IBMJava2-JRE-142.ia64.tgz
945d2203ee5a6ec9c7770cb26c7bd37a *IBMJava2-JRE-142.ppc.tgz
fb491ed13144238c0aebb123eead1388 *IBMJava2-JRE-142.ppc64.tgz
8ea56e630a476abda6fb8b28de074d3e *IBMJava2-JRE-142.s390.tgz
ba6f9639f385af3a0cfd9bd81c1a6ab8 *IBMJava2-JRE-142.s390x.tgz
39929f487a2b9a726ba35fb0e47fcfa5 *IBMJava2-JRE-142.tgz
5310f13bb9b40432667d60ab7a3aa75f *IBMJava2-JRE-AMD64-142.x86_64.tgz
81e5699df94e84210808f41b14bb117f *IBMJava2-SDK-142.ia64.tgz
352b5d4faf6c0adc1131467395a4556c *IBMJava2-SDK-142.ppc.tgz
6f7b1990a9af72b8e1d6753fe5b7294e *IBMJava2-SDK-142.ppc64.tgz
72aa9c762d139ee49f2b20df0d67f5ea *IBMJava2-SDK-142.s390.tgz
cb2a9f0ac5f9d9ee9e84e294b4a2f1af *IBMJava2-SDK-142.s390x.tgz
126cdd520a0cba74918ec3b1d2e969f2 *IBMJava2-SDK-142.tgz
f870f8f0902e6bc17bc4b3edd65a5259 *IBMJava2-SDK-AMD64-142.x86_64.tgz
Comment 17 Vadim Nasardinov 2005-07-29 13:22:43 EDT
Created attachment 117278 [details]
testcase showing that SR2 fixes this buh

The attached testcase shows that this bug is resolved by SR2.
Speficically, the attached script only tests the following JDK:

126cdd520a0cba74918ec3b1d2e969f2  IBMJava2-SDK-142.tgz

This is because the bug only affected the 32-bit x86 version of the
JDK.
Comment 20 Red Hat Bugzilla 2005-10-05 09:45:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-302.html

Note You need to log in before you can comment on or make changes to this bug.