This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 150244 - fetchmail isn't rebuildable against krb5 1.4; krb5_init_ets()
fetchmail isn't rebuildable against krb5 1.4; krb5_init_ets()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 16:56 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 6.2.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 08:14:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-03 16:56:00 EST
Description of problem:
fetchmail isn't rebuildable against krb5 1.4; fails at krb5_init_ets().

Version-Release number of selected component (if applicable):
fetchmail-6.2.5-6

How reproducible:
Everytime.

Steps to Reproduce:
1. Try to rebuild latest fetchmail against krb5 1.4
2. Fail with an error message to krb5_init_ets().
  
Actual results:
The following patch works for me, maybe for upstream this should be made
conditional:

--- snipp ---
--- fetchmail-6.2.5/driver.c            2005-03-02 18:02:50.000000000 +0100
+++ fetchmail-6.2.5/driver.c.krb5_ets   2005-03-02 18:03:13.000000000 +0100
@@ -210,7 +210,6 @@
     krb5_auth_context auth_context = NULL;

     krb5_init_context(&context);
-    krb5_init_ets(context);
     krb5_auth_con_init(context, &auth_context);

     if (retval = krb5_cc_default(context, &ccdef)) {
--- snapp ---

Expected results:
Apply of this patch or better ;-)
Comment 1 Robert Scheck 2005-03-14 11:12:01 EST
Oh and rebuilding of fetchmail against gcc4/glibc 2.3.4 worked for me without 
any further patch.
Comment 2 Robert Scheck 2005-03-17 08:14:09 EST
Thanks for applying this patch to 6.2.5-7, closing now.

Note You need to log in before you can comment on or make changes to this bug.