Bug 150266 - include/asm-x86_64 depends on include/asm-i386
include/asm-x86_64 depends on include/asm-i386
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 19:18 EST by H. Peter Anvin
Modified: 2015-01-04 17:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 03:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2005-03-03 19:18:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0

Description of problem:
The Fedora kernel includes the build headers for the kernel in /lib/modules/*/build.  In doing so, it prunes unneeded architectures.  Unfortunately, the asm-x86_64 headers frequently #include asm-i386 headers, and thus, on x86_64, asm-i386 needs to be included as well.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1. cd /lib/modules/`uname -r`/build/include/asm-x86_64
2. grep asm-i386 *
  

Actual Results:  cpu.h:#include <asm-i386/cpu.h>
ide.h:#include <asm-i386/ide.h>
node.h:#include <asm-i386/node.h>


Expected Results:  No includes should have been found, *or* asm-i386 is needed.

Additional info:
Comment 1 Orion Poplawski 2005-06-06 12:03:48 EDT
Causing driver build problems in pre-FC4 as well.
Comment 2 Dave Jones 2005-07-15 14:49:37 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Orion Poplawski 2005-07-18 16:38:20 EDT
This is still an issue with 2.6.12-1.1372_FC3
Comment 4 Dave Jones 2005-09-26 18:17:48 EDT
fix checked into cvs, will be in next errata.
Comment 5 Fedora Update System 2005-09-29 23:11:13 EDT
From User-Agent: XML-RPC

kernel-2.6.13-1.1526_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Dave Jones 2005-09-30 01:10:01 EDT
ignore that last comment, I mistakenly put this bug id in the FC4 announce.
An FC3 build with this fix will happen soon (I just need to fix up some other
problems first).
Comment 7 Fedora Update System 2005-10-20 10:29:05 EDT
From User-Agent: XML-RPC

kernel-2.6.12-1.1380_FC3 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.