Bug 150276 - Connect to Server in Places Menu doesn't work as expected for SSH connection type
Connect to Server in Places Menu doesn't work as expected for SSH connection ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-03 23:41 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 20:08:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-03-03 23:41:15 EST
Description of problem:
using the menu bar applet which provides the
"Applictions Places Desktop"  menu bar.

Using the Places->Connect to Server  item
Service Type: ssh
Name to use for connection: Test SSH Server
I get an error dialog:
"Can't display location sftp://user@server
there is no default action associated with this location"

And now the Places menu in the menu bar has an entry for
'Test SSH Server' which I can not be removed from the menu via the ui.
Right clicking tries to mount the sftp location which just gives me
the error dialog again.

Service Type: Public ftp   works as expected for me.


Version-Release number of selected component (if applicable):
gnome-applets-2.9.6-2 and gnome-panel-2.9.91-3


How reproducible:
Anytime I want to try to connect to an ssh server i get this behavior.

Expected results:
I would like ssh service type to work.. and when it doesn't work I
would like to be able to clear out the Places menu of network shares
that are not working.
Comment 1 Ray Strode [halfline] 2005-08-31 12:10:51 EDT
This seems to work fine for me.

Are you still seeing the problem?
What happens if you go to a nautilus window, press ctrl-L and then type
sftp://user@server . Does that work?
Comment 2 Jef Spaleta 2005-08-31 20:08:53 EDT
Looks like the server connection is working. I'll close this bug out.

I wish there was a way to unmount the server connections from the Places menu.
Having to go into the Computer window or reach for the desktop icon to unmount
seems a bit asymmetrical to me. But that is clearly a feature request to be filed.

-jef

Note You need to log in before you can comment on or make changes to this bug.