Bug 150284 - restarting dhcp shows copyright
Summary: restarting dhcp shows copyright
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-04 09:26 UTC by Herbert Gasiorowski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: dhcp-3.0.1-42_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-01 21:54:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Herbert Gasiorowski 2005-03-04 09:26:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
restarting dhcpd allways shows the copyright notice.



Version-Release number of selected component (if applicable):
dhcp-3.0.1-40_FC3

How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/dhcpd restart
2.
3.
    

Actual Results:  Internet Systems Consortium DHCP Server V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
Shutting down dhcpd: [  OK  ]
Starting dhcpd: [  OK  ]


Expected Results:  Shutting down dhcpd: [  OK  ]
Starting dhcpd: [  OK  ]


Additional info:

This is due to a call of dhcpd in configtest().
Adding the flag -q to that line would help me quite a bit
(I changed it before, but the update reverts to the old behaviour):

*** /etc/rc.d/init.d/dhcpd      2005-02-25 03:05:46.000000000 +0100
--- /app/fedora/3/files/patches/etc/rc.d/init.d/dhcpd   2005-03-04
10:07:56.000000000 +0100
***************
*** 35,41 ****
          if [[ "$DHCPDARGS" = *-cf* ]]; then
            CFA=`echo $DHCPDARGS | sed 's/^.*-cf[\ \    ]*/-cf/;s/[\ \
 ].*$//;s/-cf/-cf /'`;
          fi;
!       /usr/sbin/dhcpd -t $CFA
        return $?
  }
  
--- 35,41 ----
          if [[ "$DHCPDARGS" = *-cf* ]]; then
            CFA=`echo $DHCPDARGS | sed 's/^.*-cf[\ \    ]*/-cf/;s/[\ \
 ].*$//;s/-cf/-cf /'`;
          fi;
!       /usr/sbin/dhcpd -t -q $CFA
        return $?
  }


Note You need to log in before you can comment on or make changes to this bug.