This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 150286 - rebuild of clumanager fails
rebuild of clumanager fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 04:49 EST by Need Real Name
Modified: 2009-04-16 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 10:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-04 04:49:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020 Epiphany/1.4.4

Description of problem:
A rebuild of clumanager on FC3 fails:

# rpmbuild --rebuild clumanager-1.2.3-1.src.rpm
[snip]
gcc -c ops.c -I. -I.. -I../../../include -I../../../librhcm -I../../clulib -I/usr/include/libxml2 -Wall -Werror -Wstrict-prototypes -Wshadow -ggdb -fpic -DVERSION="\"1.2.3\"" -pthread
ops.c: In function `shared_raw_read_atomic':
ops.c:106: warning: use of cast expressions as lvalues is deprecated
ops.c: In function `shared_raw_write_atomic':
ops.c:167: warning: use of cast expressions as lvalues is deprecated
make[3]: *** [ops.o] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/clumanager-1.2.3/src/iolib/raw'
make[2]: *** [all] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/clumanager-1.2.3/src/iolib'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/clumanager-1.2.3/src'
make: *** [all] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.99097 (%build)

I saw a similar bug about this on IA64, which was fixed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Lon Hohberger 2005-03-04 10:59:49 EST
This was fixed last September.
Comment 4 Need Real Name 2005-03-04 11:21:43 EST
Looks like that page is using the wrong kind of sort to get the current versions.
Comment 5 Lon Hohberger 2007-12-21 10:10:43 EST
Fixing product name.  Clumanager on RHEL3 was part of RHCS3, not RHEL3

Note You need to log in before you can comment on or make changes to this bug.