Bug 150290 - cupsd does not run
cupsd does not run
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 05:21 EST by Boris Folgmann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-11 04:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My cupsd.conf (22.04 KB, text/plain)
2005-03-04 05:23 EST, Boris Folgmann
no flags Details

  None (edit)
Description Boris Folgmann 2005-03-04 05:21:13 EST
Description of problem:
/etc/init.d/cups start fails
Worked with previous cups RPM.

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.5
cups-libs-1.1.22-0.rc1.8.5
hal-cups-utils-0.5.2-8
libgnomecups-0.1.12-5
qtcups-2.0-15


How reproducible:
always on boot, not always afterwards

Steps to Reproduce:
Boot PC or try /etc/init.d/cups start afterwards again.

  
Actual results:
cupsd: Child exited with status 99!


Expected results:
That cupsd runs

Additional info:
My /etc/cups/printers.conf

<DefaultPrinter printer>
Info Created by redhat-config-printer 0.6.x
DeviceURI parallel:/dev/lp0
Location Kyocera FS-1750
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
<Printer printer2>
Info Created by redhat-config-printer 0.6.x
DeviceURI lpd://printer2/lp0
Location Keller
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
<Printer printer3>
Info Created by redhat-config-printer 0.6.x
DeviceURI lpd://printer2/lp0
Location Test
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
Comment 1 Boris Folgmann 2005-03-04 05:23:13 EST
Created attachment 111659 [details]
My cupsd.conf
Comment 2 Boris Folgmann 2005-03-04 05:35:15 EST
Is there any coincidence with bug 112835?
I'm using system-config-printer-0.6.116.1.1-1
Comment 3 Tim Waugh 2005-03-11 04:59:10 EST
No, it'll be because of the vmnet interface.  Make sure the vmware service
starts before cups does.
Comment 4 Boris Folgmann 2005-03-16 04:27:24 EST
Instead of fiddling about priorities in /etc/rc5.d I removed the vmnet stuff in
cupsd.conf. Now it works, but this is certainly a bug, since cupsd doesn't log
anything useful about this problem. IMHO it would be even better if cups would
run and ignore the problematic line in cupsd.conf (still logging it). This would
be more fail-safe.
Will somebody ask vmware to start their interface before cups?

Note You need to log in before you can comment on or make changes to this bug.