Bug 150306 - 2 * local variable used before set
2 * local variable used before set
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: uqm (Show other bugs)
3
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
http://uqm.stack.nl/cgi-bin/bugs/show...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 10:48 EST by David Binderman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 12:47:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-03-04 10:48:33 EST
Description of problem:

I just tried to compile uqm-0.3-3 from Redhat Fedora Extras development
tree with the Intel C compiler.

The compiler said

1.

src/sc2code/libs/graphics/font.c(229): remark #592: variable "locPrim"
is used before its value is set

The source code is

                PRIMITIVE locPrim;
                TFB_Palette color;
                DWORD c32k;

                if (FontEffect.Use)
                        SetPrimType (&locPrim, STAMP_PRIM);

Suggest init locPrim before first use.  SetPrimType reads from locPrim
before setting a value in p.

2.

src/sc2code/planets/scan.c(599): remark #592: variable "p" is used
before its value is set

The source code is

        PRIMITIVE p;
        Task task = (Task) data;

        SetPrimType (&p, STAMPFILL_PRIM);

Duplicate. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ville Skyttä 2005-03-04 12:47:21 EST
http://uqm.stack.nl/cgi-bin/bugs/show_bug.cgi?id=702

If you have a reproducable case of the compiled program malfunctioning
due to errors related to these compiler warnings, feel free to reopen
this bug and set priority and severity accordingly.

Note You need to log in before you can comment on or make changes to this bug.