Bug 150309 - Mouse pointer jumps when resizing window
Mouse pointer jumps when resizing window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 150311 156512 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 11:07 EST by August
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 10:48:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description August 2005-03-04 11:07:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
If I have a resizable non-maximized window that's aligned with the top of (or near the top of) the screen and I drag the top edge of the window to decrease its height, the mouse pointer jumps about one cm to the right just before the pointer shape turns into an up-down arrow.

Version-Release number of selected component (if applicable):
metacity-2.8.6-2

How reproducible:
Always

Steps to Reproduce:
1. Launch any application that has a resizable window, for instance gedit.

2. Make sure the window is not maximized and move it to the topmost position on the screen (as far up as possible).

3. Move the mouse pointer towards the top edge of the window until the pointer shape turns into an up-down arrow.


  

Actual Results:  The mouse pointer jumps about one cm to the right just before the pointer shape turns into an up-down arrow.

Expected Results:  No jump, continuous movement.

Additional info:

This happens with all window themes i have tried. My screen resolution is 800x600.
Comment 1 Marius Andreiana 2005-05-11 06:31:41 EDT
I can't reproduce this in FC4t3.
Comment 2 August 2005-05-11 10:46:38 EDT
Actually, now I can't reproduce it either with my current setup FC3 (kernel
2.6.11-1.14_FC3). Don't know which update fixed the problem, but now it seems to
be solved.
Comment 3 Ray Strode [halfline] 2005-05-11 10:48:24 EDT
Great. I'll close this then.  Thanks guys.
Comment 4 Marius Andreiana 2005-05-12 09:34:51 EDT
*** Bug 156512 has been marked as a duplicate of this bug. ***
Comment 5 Marius Andreiana 2005-05-12 09:36:18 EDT
*** Bug 150311 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.